We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Close
Answered

Keep on getting Low Memory (RAM) issue (due to dllhost.exe) on my laptop

TheShadowWalkerTheShadowWalker

Can anybody help? I've tried re-installing windows and now after about a month it has happened again, my computer freezes. Turns out my Memory Usage is 99% max out nearing 4GB and is caused by a process called dllhost.exe that's using most of the memory. This happens even when I just leave the laptop on for awhile and come back to it later, everything just freezes. There's only 1 browser with 1 tab open and it always happens. Any solutions? I feel like throwing my laptop to the wall as my Smartphone is so much more fluid/smoother than it :/

Thanks.

Best Answer

All Responses (9)

Jump to unread Post an Answer
    MJV
    MIDURIX
    Yeah, as above. If it is a proper windows process it shouldn't be giving you issues. You will only experience issues if it is malware.
    nemesiz
    To answer your problem please could you provide your exact specifications, software (programs running in the background) and hardware (including make and model of laptop) as it's difficult to ascertain what is causing the problem. The fault could be caused by any number of things such malware, anti-virus, overheating, software error, multiple programs, malicious scripting or hacking, processor or memory fault etc.
    TheShadowWalker
    nemesiz
    To answer your problem please could you provide your exact specifications, software (programs running in the background) and hardware (including make and model of laptop) as it's difficult to ascertain what is causing the problem. The fault could be caused by any number of things such malware, anti-virus, overheating, software error, multiple programs, malicious scripting or hacking, processor or memory fault etc.


    From what I've gathered from Google it's something wrong with Explorer, when opening video files where thumbnails need to be loaded. But I can't seem to find a solution for it? I don't want to just terminate it as it might be important.

    All I have open usually is Chrome or Firefox, and two word documents open. One of the internet browser tab would be a video on the projectfreetv site. I don't know when exactly the problem arises, but after a while my computer starts to lag/freeze (maybe 1-2 hours later).

    I've already re-installed windows a month ago and have Avast Anti-virus installed. Have barely installed anything on this laptop apart from the usual browsers and antivirus. I'm using Alienware m11x R1 laptop. I was thinking it may be a RAM fault :/. I've owned the laptop about 3 years now I think.
    MIDURIX
    Some people have had luck in fixing it by selecting not to display thumbnails, but more people have found that it is a single video sitting amongst your collect which is messing it up. You might have a movie called blahblah and another one called blahblah(1) because it is a duplicate it has (1) at the end and it might give you some trouble deleting it. Sounds weird but has happened to several people after looking round.
    nemesiz
    This link has a possible solution to the dllhost.exe / com-surrogate problem, whether this will resolve you fault is another matter.

    http://answers.microsoft.com/en-us/windows/forum/windows_7-files/why-does-dllhostexe-com-surrogate-consumes-memory/bd7e42bb-802d-4eb9-95b2-2bb6b566996d


    Edited By: nemesiz on Jul 10, 2013 18:23: .
    TheShadowWalker
    nemesiz
    This link has a possible solution to the dllhost.exe / com-surrogate problem, whether this will resolve you fault is another matter.

    http://answers.microsoft.com/en-us/windows/forum/windows_7-files/why-does-dllhostexe-com-surrogate-consumes-memory/bd7e42bb-802d-4eb9-95b2-2bb6b566996d



    Yeah I did read that, not much help. Anyway, after reading a ton of articles I've found a solution. It's to do with creating thumbnails for 3D videos. I downloaded of youtube an LG 3D demo and everytime I access the folder where it was stored, after a while that dllhost issue appeared. After I've deleted the 3D file the issue doesn't pop up anymore. I hope this will help anyone else in the future who might encounter this problem.

    Thanks for all your help guys!
    Doculean
    I tried that myself, the issue with kb2670383, problem is. I am having this issue despite not having either IE10 or kb3670838 on my computer with a fresh fully updated install. It generally happens when I have a folder with a ton of stuff in it... Anyway. When it happens I just close the process, I don't worry about it as it starts right back up anyway. I think it has something to do with icon creation or thumbnails in metadata. Not sure, cause I can have the issue with even a folder full of txt files and even music.
    TheShadowWalker
    Doculean
    I tried that myself, the issue with kb2670383, problem is. I am having this issue despite not having either IE10 or kb3670838 on my computer with a fresh fully updated install. It generally happens when I have a folder with a ton of stuff in it... Anyway. When it happens I just close the process, I don't worry about it as it starts right back up anyway. I think it has something to do with icon creation or thumbnails in metadata. Not sure, cause I can have the issue with even a folder full of txt files and even music.


    For me, any other folder I have is fine. Only the ones with 3d movies in the folder (where it'll need the thumbnails to load), then only will dllhost process start, and I'd have to close the folder and end the process. Maybe you have a torrent or download folder with some sort of 3d clip you forgot about.

Post an Answer

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

I Approve
Your Comments On This Post
Comment Preview
Close

PRIVATE MESSAGE

Close
Sorry, you can’t currently send PMs. Once you’re a more active member of the forum, the PM service will be unlocked for you.
Welcome to HUKD!
Close
Join the Community