lpg on car switches over to petrol - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HotUKDeals, you accept our cookie and privacy policy.
Get the HotUKDeals app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

lpg on car switches over to petrol

£0.00 @
I have a a stag lpg kit in my car but it switches over to petrol and beeps after doing about 160 170 miles. what would the issue be I don't think it's a issue with the outside temperatures . as in the… Read More
MynameisM Avatar
4m, 1w agoPosted 4 months, 1 week ago
I have a a stag lpg kit in my car but it switches over to petrol and beeps after doing about 160 170 miles. what would the issue be I don't think it's a issue with the outside temperatures . as in the winter it's been fine even in minus temperatures. it did this last year aswell a few times I'm really not sure what it is I don't think it's the filter as when I had the filter changed last time it did that aswell. any ideas the reason I know it's not the gas hasn't run out is because when I fill it up I only get between 25/27 ) litres in usually I can get 40-43 litres. when it actually runs out. it's annoying Any input or ideas appreciated thanks.
MynameisM Avatar
4m, 1w agoPosted 4 months, 1 week ago
Options

All Responses

(17) Jump to unreadPost an answer
Responses/page:
#1
Not sure to be honest. But on large lpg space heaters they are prone to freezing up around the the pressure regulator after a couple of hours continual use and this restricts the flow and reduces/stops heat output.
#2
get a diesel, ruin the environment, save money
#3
Try posting here. Sounds like a calibration issue to me. Polish but there are English posts there.

https://forum.ac-sa.eu/search.php?search_id=active_topics

Have you run the diagnostics program?

Edited By: getmeone on Mar 18, 2017 20:54: Data
#4
HamanBasher
get a diesel, ruin the environment, save money


Get electric car eat quorn and stop washing. Doesnt save the environment but gives the rest of us a good laugh lol
banned#5
Hhahaha i remember that happened and we didn't realise.
just keep switching it back again. maybe take it to a lpg specialist mechanic. but lpg work are expensive stuff.
#6
getmeone
Try posting here. Sounds like a calibration issue to me. Polish but there are English posts there.

https://forum.ac-sa.eu/search.php?search_id=active_topics

Have you run the diagnostics program?


I have tried that link but struggling with the Polish lol. how do I run a diagnostic program will I need any special stuff I have a obd2 conector can I use that to do it.
#7
Could be dirt in your valve. I has a similar issue when I had a gas vehicle. Go to specialist and he will plug in and tell you. Mine came up with lack of gas but was full. Could be your tanks gas pipe has moved so you can't take the rest . Check your water as low level can freeze your valve. These valves are heated by your engine hence you run for a mile or so until it kicks in. Good luck
#8
MynameisM
getmeone
Try posting here. Sounds like a calibration issue to me. Polish but there are English posts there.https://forum.ac-sa.eu/search.php?search_id=active_topics
Have you run the diagnostics program?
I have tried that link but struggling with the Polish lol. how do I run a diagnostic program will I need any special stuff I have a obd2 conector can I use that to do it.
I doubt any lpg issue would show up via normal obd scanners. I would go to an lpg specialist.
#9
Daveycaz
Could be dirt in your valve. I has a similar issue when I had a gas vehicle. Go to specialist and he will plug in and tell you. Mine came up with lack of gas but was full. Could be your tanks gas pipe has moved so you can't take the rest . Check your water as low level can freeze your valve. These valves are heated by your engine hence you run for a mile or so until it kicks in. Good luck


that would be the case if it didn't switch over at all its mainly to do with it telling me it's finished when it hasn't that's the issue bit different than not switching over at all that's what stumps me.
#10
MynameisM
getmeone
Try posting here. Sounds like a calibration issue to me. Polish but there are English posts there.https://forum.ac-sa.eu/search.php?search_id=active_topics
Have you run the diagnostics program?
I have tried that link but struggling with the Polish lol. how do I run a diagnostic program will I need any special stuff I have a obd2 conector can I use that to do it.
What model do you have?
#11
the obd2 adapter 8s a elm 327or u mean the lpg kit it's ac stag kit it's says it's a ac qbox and the tank is a stako on a Toyota corolla verso.
#12
getmeone
MynameisM
getmeone
Try posting here. Sounds like a calibration issue to me. Polish but there are English posts there.https://forum.ac-sa.eu/search.php?search_id=active_topics
Have you run the diagnostics program?
I have tried that link but struggling with the Polish lol. how do I run a diagnostic program will I need any special stuff I have a obd2 conector can I use that to do it.
What model do you have?


the obd2 adapter 8s a elm 327or u mean the lpg kit it's ac stag kit it's says it's a ac qbox and the tank is a stako on a Toyota corolla verso.
#13
The fuel level indicator/Sensor on the Stako should be a 0-90ohm type. A first check would be to check the resisitance on the sensor itself. There is a cable with two wires running of to the STAG to tell it how much gas is in the tank. The sensor will measure 90ohms when full and Zero ohms when empty. Fill the tank and measure the resistance across the two terminals. It should be 90ohms full. Run the car until it switches over to petrol and recheck the resistance across the terminals. If you have a reading of 0, the sensor is naff. If you have a reading of 45 ohms, meaning half full, then there is a problem with the settings/electronics in the STAG. You will need a fairly accurate Ohmeter fo the initial tests. If it is not that and you are inclined to investigate further yourself, purchase the USB to STAG cable and download the software from AC. Check but I think it is cable 3.

http://www.ebay.ie/itm/5-types-LPG-CNG-diagnostic-INTERFACE-USB-CABLE-KME-TECH-STAG-ZAVOLI-LANDI-DVD-/192099323276?hash=item2cba030d8c:g:euMAAOSwPCVX7WFL
#14
ok thanks mate I know the fuel gauge isn't set up properly basically the garage guys set it up incorrectly when it's fully charge it shows nearly empty and when I drive over 120 miles it shows full. how does the gauge affect the gas supply by stopping it. when it stops the lights are still all on just the light flashes green and beeps and switches over to petrol.
#15
getmeone
The fuel level indicator/Sensor on the Stako should be a 0-90ohm type. A first check would be to check the resisitance on the sensor itself. There is a cable with two wires running of to the STAG to tell it how much gas is in the tank. The sensor will measure 90ohms when full and Zero ohms when empty. Fill the tank and measure the resistance across the two terminals. It should be 90ohms full. Run the car until it switches over to petrol and recheck the resistance across the terminals. If you have a reading of 0, the sensor is naff. If you have a reading of 45 ohms, meaning half full, then there is a problem with the settings/electronics in the STAG. You will need a fairly accurate Ohmeter fo the initial tests. If it is not that and you are inclined to investigate further yourself, purchase the USB to STAG cable and download the software from AC. Check but I think it is cable 3.

http://www.ebay.ie/itm/5-types-LPG-CNG-diagnostic-INTERFACE-USB-CABLE-KME-TECH-STAG-ZAVOLI-LANDI-DVD-/192099323276?hash=item2cba030d8c:g:euMAAOSwPCVX7WFL


where will the wires be to check the sensor any idea.
#16
http://i.ebayimg.com/00/s/NTAwWDk2OA==/z/N7wAAOSwYaFWeALO/$_57.JPG?set_id=880000500F
#17
MynameisM
ok thanks mate I know the fuel gauge isn't set up properly basically the garage guys set it up incorrectly when it's fully charge it shows nearly empty and when I drive over 120 miles it shows full. how does the gauge affect the gas supply by stopping it. when it stops the lights are still all on just the light flashes green and beeps and switches over to petrol.
Read this post second. Will PM YOU now.

Post an Answer

You don't need an account to leave a response. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!