I'm having problems with my piaggio zip starting and running - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HotUKDeals, you accept our cookie and privacy policy.
Get the HotUKDeals app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

I'm having problems with my piaggio zip starting and running

£0.00 @
So I haven't rode my 2008 piaggio zip 50 4T in a while and when I went to start it I killed the battery trying to electric start it, I live in England so it's pretty cold, I then spent 10 minutes tryi… Read More
I1337bamf Avatar
2y, 4m agoPosted 2 years, 4 months ago
So I haven't rode my 2008 piaggio zip 50 4T in a while and when I went to start it I killed the battery trying to electric start it, I live in England so it's pretty cold, I then spent 10 minutes trying to kick start it and eventually got it running, the bike really struggled, it was incredibly sluggish and struggled to accelerate, it wouldn't go any faster than 20mph down a big hill and 15mph on the flats, I figured it wasn't getting spark because the starter motor was cranking the engine, I noticed that I could get it to accelerate a but more faster once it stopped at a certain speed by coming off the throttle and going straight back on. I could tell the bike was running rich because the whole time trying to start it the throttle was wide open and you could smell it, I decided to remove the spark plug and it had what looked like oil on it, not a massive amount just a thin layer, I also noticed the Ht lead had split and I could see exposed metal, the previous owner covered it with electrical tape but it didn't do much, so I'm thinking that it could be earthing through the frame of the bike without making it to the spark plug, I'm thinking of replacing the ht lead and coil pack. Any suggestions would be much appreciated. I will post the link to the original question on yahoo as it has a picture of the spark plug. https://uk.answers.yahoo.com/question/index;_ylt=AhOmCDQgv4pPbnAepDVKxdbc4yA5?qid=20141231014103AAS0X7W
I1337bamf Avatar
2y, 4m agoPosted 2 years, 4 months ago
Options

All Responses

(11) Jump to unreadPost an answer
Responses/page:
#1
Yes new ht lead will do the trick.
#2
As above, you could see if you can find some thick'ish rubber or other insulating material and wrap it around the ht lead and try it again to see if it's any better, just in case you buy a new ht lead and coil pack that you don't need.
#3
Do you need to replace the coil and lead? Are these a combined unit on bikes?
banned#4
clean the carb and it will be fine
#5
Run in the dark . If theres a problem with the HT side you will see sparks tracking around the HT lead /cap . If there is tracking you may temporarily fix it it by wrapping the offending area with insulating tape or self vulcanising rubber tape . Also bear in mind small single cylinder engines dont like the cold . If you get it going give it a decent run , charge the battery and it may well be ok . Just thought does it have an automatic choke ? May be stuck full on if you haven't used it for a while -would explain your lack of power .

Edited By: rogparki on Dec 31, 2014 12:38: addition
#6
OK so I have found many problems in my foraging lol, I found that the fuel tank was punctured, the fuel line is blocked, there is no fuel filter and an electrical unit is a bit broke and I'm not sure of its name, I have a picture of it, it's located on the left side of the bike near my feet, http://tinypic.com/r/6tnv3k/8http://tinypic.com/r/v80ysh/8 those are the pictures of it, if anyone knows what it's called I would be greatful to know as I need to order a new one
#7
Buy a new spark NGK plug cap the same shape as the one you already have, but back the HT lead a little and screw on the new cap, you probably don't need a complete coil and lead, fit that and that bit will be sorted.

Blocked fuel lines will cause running problems as the fuel flow will be restricted by the blockage, obviously the tank needs replacing or repairing so you could do both jobs at once.

The thing in the photo's looks to be a starter motor solenoid judging by the thickness of the 2 red wires compared to the others, does it click when you press the starter?
#8
Yes from the pic looks like the starter motor relay ,or maybe the indicator relay . A you said it was cranking ok (albeit with a v.low battery) unlikely to be that. Could be a fuel line blockage if the tank puncture was caused by rust . Disconnect pipe ,both ends and blow through (are you sure there isn't a petrol On/Reserve/Off tap ?) . May sound daft but I've turned mine off and forgotten till it spluttered to a stop half a mile down the road :) . Wont pass an MOT with a holed fuel tank so you'll need to replace that at some point .

Edited By: rogparki on Dec 31, 2014 15:49
#9
As the tank is plastic and it's already passed the mot, would I be able to just put a shorter screw into the tank and glue it in? I only need the bike for 4 more months and then I'm selling it
#10
I1337bamf
As the tank is plastic and it's already passed the mot, would I be able to just put a shorter screw into the tank and glue it in? I only need the bike for 4 more months and then I'm selling it
Should be ok as long as the glue isn't dissolved by the fuel .
#11
I was going to use standard super glue, it won't be in the tank, I'll put the screw in all the way, glue over it to seal itfully and then maybe put some electrical ttape over it

Post an Answer

You don't need an account to leave a response. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!