PC SSD Bad Blocks - Advice please! - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HotUKDeals, you accept our cookie and privacy policy.
Get the HotUKDeals app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

PC SSD Bad Blocks - Advice please!

£0.00 @
Windows 7 has struggled to boot successfully over the last 36 hours. Sometimes it hangs at the login screen (keyboard becomes unresponsive), sometimes stuck post-login, usually a few seconds after boo… Read More
Firefly1 Avatar
2m, 2w agoPosted 2 months, 2 weeks ago
Windows 7 has struggled to boot successfully over the last 36 hours. Sometimes it hangs at the login screen (keyboard becomes unresponsive), sometimes stuck post-login, usually a few seconds after boot up. File explorer would not load on one occasion and then again, everything unresponsive (no blue screens etc).

Eventually did a quick virus scan, nothing.

Attempted system restore to 1 week ago, it failed.

I went into Event Viewer and it States about 40-50 error messages over the last 2 days of: "Disc - The device \Device \Harddisk0\ DR0, has a bad block."

Checked SSD life via a hardware monitor app and it says 98% remaining life.

Will back things up as soon as I get access to another drive, currently away from home.

Anything else I should/shouldn't be doing?

Thanks guys.
Tags:
Firefly1 Avatar
2m, 2w agoPosted 2 months, 2 weeks ago
Options

All Responses

(13) Jump to unreadPost an answer
Responses/page:
#1
That SSD is dying I think. You can try sfc and see if it is just logical file system errors but I doubt it.
#2
Spark
That SSD is dying I think. You can try sfc and see if it is just logical file system errors but I doubt it.

It took about 10 reboots this afternoon, some in safe mode, to get it on with chrome open. I'm backing up my uni files to the Cloud as I'm not convinced it will turn on many more times :(

Won't go hunting in any settings until my uploads to the cloud are done, but I'll try that next.
#3
Firefly1
Spark
That SSD is dying I think. You can try sfc and see if it is just logical file system errors but I doubt it.
It took about 10 reboots this afternoon, some in safe mode, to get it on with chrome open. I'm backing up my uni files to the Cloud as I'm not convinced it will turn on many more times :(
Won't go hunting in any settings until my uploads to the cloud are done, but I'll try that next.

There's a free tool called ASSD Workbench that will tell you whether or not the drive is in good health and running up to code but in your case I'm expecting that tool to fail.
#4
How long have you had the ssd as a lot of manufacturers offer 5 or 10 year warranty on them, best to run a disk check, you say win 7, how old is the install? It could just need a fresh install for the registry etc, but check the disk first with smart tests, if that's fine then proper format and re install should fix it

Edited By: westy125 on Feb 03, 2017 17:12: error
#5
westy125
How long have you had the ssd as a lot of manufacturers offer 5 or 10 year warranty on them, best to run a disk check, you say win 7, how old is the install? It could just need a fresh install for the registry etc, but check the disk first with smart tests, if that's fine then proper format and re install should fix it

The driver date is June 2006, so that long ;) I didn't realise it was one of my original M4 v1 512GB ssds, rather than a more modern one!

I should add the laptop isn't that old, circa 2013.

Edited By: Firefly1 on Feb 03, 2017 17:41
#6
Try a different cable and port on the motherboard - otherwise try Spinright from Steve Gibson.
#7
Firefly1
westy125
How long have you had the ssd as a lot of manufacturers offer 5 or 10 year warranty on them, best to run a disk check, you say win 7, how old is the install? It could just need a fresh install for the registry etc, but check the disk first with smart tests, if that's fine then proper format and re install should fix it

The driver date is June 2006, so that long ;) I didn't realise it was one of my original M4 v1 512GB ssds, rather than a more modern one!

I should add the laptop isn't that old, circa 2013.


Ok, but when did you last install Windows? If it's 2013 then backup your data, and format that ssd (not quick format) and re install! To be honest if my ssd was 11 years old I would probably get rid
#8
Check your firmware as the M4 has been known to play up.
http://uk.crucial.com/gbr/en/support-ssd-firmware
#9
westy125
Firefly1
westy125
How long have you had the ssd as a lot of manufacturers offer 5 or 10 year warranty on them, best to run a disk check, you say win 7, how old is the install? It could just need a fresh install for the registry etc, but check the disk first with smart tests, if that's fine then proper format and re install should fix it
The driver date is June 2006, so that long ;) I didn't realise it was one of my original M4 v1 512GB ssds, rather than a more modern one!

I should add the laptop isn't that old, circa 2013.

Ok, but when did you last install Windows? If it's 2013 then backup your data, and format that ssd (not quick format) and re install! To be honest if my ssd was 11 years old I would probably get rid
Latenight ? ;) The M4s were released in 2011, he's just quoting the device driver which will be a default ms one :)
#10
Search for hirens boot cd, burn it to disc and boot from it. It has all kinds of disc tools in it and you will probably be able to skip the bad sector. it sounds like your disc is physically on the way out, i would look at getting another asap.
#11
kester76
westy125
Firefly1
westy125
How long have you had the ssd as a lot of manufacturers offer 5 or 10 year warranty on them, best to run a disk check, you say win 7, how old is the install? It could just need a fresh install for the registry etc, but check the disk first with smart tests, if that's fine then proper format and re install should fix it
The driver date is June 2006, so that long ;) I didn't realise it was one of my original M4 v1 512GB ssds, rather than a more modern one!
I should add the laptop isn't that old, circa 2013.
Ok, but when did you last install Windows? If it's 2013 then backup your data, and format that ssd (not quick format) and re install! To be honest if my ssd was 11 years old I would probably get rid
Latenight ? ;) The M4s were released in 2011, he's just quoting the device driver which will be a default ms one :)

Good shout, albeit driver confusing me! I knew the SSD was significantly older than the laptop.... Will be 2011 then :) Cost an arm and a leg at the time.

Thank you everybody for all the advice. I'll work on some of it tonight.

Edited By: Firefly1 on Feb 03, 2017 20:07
#12
kester76
westy125
Firefly1
westy125
How long have you had the ssd as a lot of manufacturers offer 5 or 10 year warranty on them, best to run a disk check, you say win 7, how old is the install? It could just need a fresh install for the registry etc, but check the disk first with smart tests, if that's fine then proper format and re install should fix it
The driver date is June 2006, so that long ;) I didn't realise it was one of my original M4 v1 512GB ssds, rather than a more modern one!

I should add the laptop isn't that old, circa 2013.

Ok, but when did you last install Windows? If it's 2013 then backup your data, and format that ssd (not quick format) and re install! To be honest if my ssd was 11 years old I would probably get rid
Latenight ? ;) The M4s were released in 2011, he's just quoting the device driver which will be a default ms one :)


Aha, I was watching grand tour while I read and typed!
#13
westy125
kester76
westy125
Firefly1
westy125
How long have you had the ssd as a lot of manufacturers offer 5 or 10 year warranty on them, best to run a disk check, you say win 7, how old is the install? It could just need a fresh install for the registry etc, but check the disk first with smart tests, if that's fine then proper format and re install should fix it
The driver date is June 2006, so that long ;) I didn't realise it was one of my original M4 v1 512GB ssds, rather than a more modern one!

I should add the laptop isn't that old, circa 2013.

Ok, but when did you last install Windows? If it's 2013 then backup your data, and format that ssd (not quick format) and re install! To be honest if my ssd was 11 years old I would probably get rid
Latenight ? ;) The M4s were released in 2011, he's just quoting the device driver which will be a default ms one :)


Aha, I was watching grand tour while I read and typed!


What's it like ? keep meaning to watch it but haven't got round to it yet :)

Post an Answer

You don't need an account to leave a response. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!