Strange External HDD Issue - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HotUKDeals, you accept our cookie and privacy policy.
Get the HotUKDeals app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

Strange External HDD Issue

£0.00 @
I have a Western Digital 1TB USB 3.0 Hard Drive which works perfectly on any USB port on my laptop. I then bought an Inateck external caddy for a 500GB drive I removed from a PS4. If I plug the … Read More
superfreddy Avatar
2m, 1w agoPosted 2 months, 1 week ago
I have a Western Digital 1TB USB 3.0 Hard Drive which works perfectly on any USB port on my laptop.

I then bought an Inateck external caddy for a 500GB drive I removed from a PS4.

If I plug the external into a USB 2.0 it's fine, but on a USB 3.0 port, the drive keeps disconnecting and reconnecting ever few seconds?

I changed the cable to the Western Digital cable and that worked fine, so is it likely to be a dodgy cable I got with my caddy? Seems weird how it'd cause this issue but be fine in a USB 2.0 port?

Any ideas? Thanks.
superfreddy Avatar
2m, 1w agoPosted 2 months, 1 week ago
Options

All Responses

(10) Jump to unreadPost an answer
Responses/page:
#1
You've answered your own question but the cable is either damaged or doesn't support usb3.
Usb3 allows for faster data and higher amp power, if the cable is cheap/damaged or just not compatible with usb3 you'll get irregular behaviour
#2
I've had issues with Inateck caddies, USB3 and different motherboard chipsets. Namely, drive working fine at USB3 on laptop but not PC. One of the issues seemed to be the motherboard header for the front panel was for 2 USB3 ports, but the case presented 1. I gave up in the end! Read lots of posts about firmware (both pc and enclosure). But...the advice to check the cable first is sound
#3
I'm still a bit confused though. None of the reviews mention anyone else having this issue?
#4
You could use usbview to check the port status (ie if running at usb superspeed, etc): http://www.techrepublic.com/blog/windows-and-office/map-and-troubleshoot-your-usb-ports-with-microsoft-usb-view/
#5
UriStamonov
You could use usbview to check the port status (ie if running at usb superspeed, etc): http://www.techrepublic.com/blog/windows-and-office/map-and-troubleshoot-your-usb-ports-with-microsoft-usb-view/

Sorry I don't understand
#6
There is a windows tool called usbview. You can run it on machine that is having problems, to check the status of the usb port when you plug in the drive. Ie: see if the drive is recognised, see if it is trying to run at full speed for usb3. I dredging this up from memory, just thought it might help troubleshooting
#7
Oh...I just re read the original post where you said you swapped the cable and it worked ok. Please ignore my ramblings!!!!!
#8
UriStamonov
There is a windows tool called usbview. You can run it on machine that is having problems, to check the status of the usb port when you plug in the drive. Ie: see if the drive is recognised, see if it is trying to run at full speed for usb3. I dredging this up from memory, just thought it might help troubleshooting

UriStamonov
Oh...I just re read the original post where you said you swapped the cable and it worked ok. Please ignore my ramblings!!!!!

That's ok. Does it sound like a faulty cable then?
#9
Ok this is weird...

So the WD external's cable works fine with my Inateck drive. The Inateck drive's cable works fine with the WD drive.

If you use the Inateck cable with the Inateck drive, that's when the problems happen. Surely if it was a fault cable, it wouldn't work fine with another hard drive, and if it was a fault caddy, it wouldn't work fine with the WD cable?!

This is a bit of a headf...
#10
Aaargh! Time for an old priest and a young priest?

Post an Answer

You don't need an account to leave a response. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!