I think my hard drive is dying - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HotUKDeals, you accept our cookie and privacy policy.
Get the HotUKDeals app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

I think my hard drive is dying

£0.00 @
I have a 3tb my book live hard drive connected to a Virgin media router.... It has been working fantastic these last few years... But all of a sudden it has stopped working and I kept a error message … Read More
b4lly87 Avatar
2w, 2d agoPosted 2 weeks, 2 days ago
I have a 3tb my book live hard drive connected to a Virgin media router.... It has been working fantastic these last few years... But all of a sudden it has stopped working and I kept a error message network not connected... I have tried restarting it and reseting it and works fine for like five minutes and then switches off and the red light on the front stops blinking... Anyone have any ideas or should I start taking my stuff off it and prepare the funeral
b4lly87 Avatar
2w, 2d agoPosted 2 weeks, 2 days ago
Options

All Responses

(17) Jump to unreadPost an answer
Responses/page:
#1
I'm sorry to hear that
#2
Prepare the longship for its burning.
#3
commiserations
#4
But seriously get the data off asap and then scan it and try and fix any errors - then prepare the longship lol
#5
You can get a program called crystal disk, this will tell you some useful info on the drive, it may just need checking for errors and re formatting,
http://crystalmark.info/software/CrystalDiskInfo/index-e.html
#6
Does it have a cooling fan? It may need vacuuming out. Shut down due to over heating? ?
#7
Take it out of the caddy and test it on a PC. Run a SMART test and see what you get back.

May very well not be the drive.
#8
Reboot it and then try accessing it with anything other than windows 10, there is something that's in the recent Windows 10 update that shuts mine down. Access from a raspberry pi was fine. As soon as I access it from Win10 it stops working again. Until its rebooted.
#9
Getting them cold may keep it running for longer. You can read on net how but yes it's on its way out I guess. Start backing up and rescue what you can
#10
Like EagleUK said, I would suggest that you try removing the drive from the case, as it's entirely possible that something else in the internals of the case has broken rather than the drive. If you have a desktop PC and a spare SATA cable, pop the side off it and attach the drive. If you have a laptop (or would just prefer a somewhat simpler approach), get yourself a SATA to USB adapter (something like this). The ones with two USB cables allow it to supply the drive with more power if needed so I prefer those. Have a spare drive ready and be prepared to get all the data off your drive ASAP in case it does turn out to be a problem with the drive. If you get all your data off and it continues to work, run a test with Crystal Disk and see what happens.
#11
Yes I'm bored, day off X)

Not exactly just a hard drive, it's network attached right? and your getting network error.

By stops blinking do you mean the LED goes out or it's stays on?, assuming I have the right product, Solid Red LED is most likely a hard drive problem.

from the manual - page 17

LED - RED Solid

Fault/action required

The following faults trigger this state:
• Disk SMART failure
• Data Volume does not exist
• System Volume does not exist
• System thermal shutdown
• Unsupported drive detected

Those are all drive errors, as you can see it also has S.M.A.R.T monitoring, which is what Crystal Disk Info would use to check the drive.

Are you using any of the WD software?

My Net View Network Evaluation Tool - provides basic network diagnostics.
WD Quick View for Windows - provides drive status information.

http://support.wdc.com/product.aspx?ID=902

If it is the drive the worse thing you can do is keep running it, don't use it until you recover your data, if windows stops recognising the drive then "File Scavenger" has saved me quite a few times recovering data.



Edited By: 4Real2016 on May 09, 2017 14:02: ;)
#12
Thanks guys I'll try it out it flashes red I think that's the error, it used to be blue. Im gonna have to get a new hardrive any suggestions network one this one has been going solid for 6years I think I got decent use out of it.... I'll try open it and operate
#13
Are you sure it's not a network issue, as it seems red can also be network issue

From the manual

The My Book Live front panel light is red and the unit's Network Adapter LEDs do not light.

1. Confirm the network cable is properly connected to the My Book Live and the network switch or router.
2. Make sure the network switch or router has power.
3. Use a different network cable and port on the network switch or router.
Temporarily swapping the My Book Live's cable port with a working network device may identify any failing cables and ports.

Edited By: 4Real2016 on May 09, 2017 16:56
#14
Call local funeral directors they will take care of everything. :p
#15
4Real2016
Are you sure it's not a network issue, as it seems red can also be network issue

From the manual

The My Book Live front panel light is red and the unit's Network Adapter LEDs do not light.

1. Confirm the network cable is properly connected to the My Book Live and the network switch or router.
2. Make sure the network switch or router has power.
3. Use a different network cable and port on the network switch or router.
Temporarily swapping the My Book Live's cable port with a working network device may identify any failing cables and ports.


The adapter lights at the back work fine, they are flashing, it's just not connecting to the network or when it does lasts all of thirty seconds
#16
I noticed My Book Live Dashboard has a drive diagnostic under utilities, but I guess you cant use it if it doesn't stay connected, unless it's long enough to run the short test.

Have you kept it's vents clean, not overheating after 5 minutes of being switched on?

Only way your know if it's the drive is to take it out and test it.


Edited By: 4Real2016 on May 09, 2017 20:50
#17
So I took it out the casing and plugged it back in, working like a dream now I don't know why or how. So now I taken the important stuff off and will see how long it lasts... Thanks for all your help... Also I broke the clips off the casing taking it off LOL Where's my electrical tape...

Post an Answer

You don't need an account to leave a response. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!