Virgin Hub 3.0 slow - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HotUKDeals, you accept our cookie and privacy policy.
Get the HotUKDeals app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

Virgin Hub 3.0 slow

£0.00 @
Just switched to Virgin from BT and have found that streaming is constantly buffering and sometimes does not work, especially on YouTube and Google play. Not very impressed with the Hub 3.0 to be hone… Read More
mike710 Avatar
1m, 1w agoPosted 1 month, 1 week ago
Just switched to Virgin from BT and have found that streaming is constantly buffering and sometimes does not work, especially on YouTube and Google play. Not very impressed with the Hub 3.0 to be honest and much preferred HH5. Has anyone else had similar issues? Is it worth using the HH5 with the Hub 3 in modem mode?
Tags:
mike710 Avatar
1m, 1w agoPosted 1 month, 1 week ago
Options

All Responses

(13) Jump to unreadPost an answer
Responses/page:
#1
Was just gonna suggest it, you will have to turn off DHCP in the HH5 if it allows, but certainly worth a shot! Also try using an ethernet cable with the Virgin Hub first to make sure its not the line/service itself.
#2
I have had problems with broadband since i got it from virgin last year with it going off all the time and having to reboot it my year is up now so going to change it they said it was my area I live in was the problem but no one else has this problem good luck i hope you can get it sorted
#3
sox5
I have had problems with broadband since i got it from virgin last year with it going off all the time and having to reboot it my year is up now so going to change it they said it was my area I live in was the problem but no one else has this problem good luck i hope you can get it sorted
Ditto constant down time , fixing issue in next two months blah blah. Now with sky and it's been rock solid
#4
We have virgin hub 3. 2 firesticks going as same time. Youtube, browsing ect. Not a glitch.. I raised hub 3 up on a shelf as height is important apparently. We needed to fit the included firestick extension cord things, as without them fitted it caused problems. Guess it acts as a aerial. No problems though day to day and we have foil backed plasterboard ceilings and solid block walls. Others reported problems though but it's a mystery why
#5
I have very few problems with mine and it sits on the floor behind the TV
#6
I went into the settings for mine and changed them to performance over distance and I get 100meg through 5g on WiFi. Live in an old brick wall house. When it was on distance settings it was actually worse. Mine is in an upstairs bedroom
#7
Is the issue on wifi or direct Ethernet cable?

First thing use a direct Ethernet cable to a computer if the problem is not there then you may need to look at the wifi settings on the router and possible change wifi channel which may be causing a conflict with neighbours.

If the problem is there on Ethernet then a call to virgin could fix the issue?

What speed are you supposed to be getting vs what are you actually getting? Have a look and run a speed test.
#8
My Virgin Broadband has been really slow, this week not sure why? I was getting a 100 Mbps last week ok.
#9
Switched to VM Hub 3 couple of weeks ago, from there Superhub 2.0(?), wireless range is greatly increased meaning I dont have to use the wireless extender I had to previously, and 2 sons haven't complained once of online gaming lagging.
#10
Performance on both Ethernet and WiFi is slow. First thing I tried was to Ethernet and it still buffers like crazy. I was trying to watch a rented film from Google Play and the quality wouldn't go above 144p!
#11
Switched to super hub 3 a few months ago after using sh2 for a few years. Not much difference in performance. Possibly better wifi performance all round . No issues with speed now...

I was under high utilization just as i upgraded to sh3. Vm do not high light the fault on the service page under ur account and will only disclose it via telephone.

Phone up vm and make sure u are not in a high utilisation area to be sure.
#12
mike710
Performance on both Ethernet and WiFi is slow. First thing I tried was to Ethernet and it still buffers like crazy. I was trying to watch a rented film from Google Play and the quality wouldn't go above 144p!


Give them a call.
#13
WDTV123
Switched to super hub 3 a few months ago after using sh2 for a few years. Not much difference in performance. Possibly better wifi performance all round . No issues with speed now...

I was under high utilization just as i upgraded to sh3. Vm do not high light the fault on the service page under ur account and will only disclose it via telephone.

Phone up vm and make sure u are not in a high utilisation area to be sure.


Can you expand on this?

Post an Answer

You don't need an account to leave a response. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!