Washing machine not draining properly - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit
Expired

Washing machine not draining properly

Sophiasky Avatar
2y, 4m agoPosted 2 years, 4 months ago
Hello, my Beko washing machine is not working properly. To start with, I removed the filter/drain cover and found a front door key along with a few other items caught in there, however, whilst trying to remove it, some of the plastic pieces inside snapped off. I fitted the cover back on and the machine was working fine, despite part of the plastic bits having snapped off.

Now, I've noticed that the machine is stopping around 24 minutes before the end of a cycle and thinks it has finished - says 'END'. I'm having to drain out the water from the bottom (via the tube) and then having to try the rinse and spin cycle, however, it does it but the clothes are still really wet and some water is still inside the machine.

Because the machine was smelling a bit, I ran it on the hottest and longest cycle and by doing that I noticed that with no clothes in the machine, all of the water drained away from the drum (still some coming out from drainage tube on the bottom). However, putting in a few clothes again (half my usual load just to test it), it stops on 24 minutes remaining, like before. I've had a look on the internet, and I think the problem might be the water pump that might need replacing - has anybody got any other ideas as to what the problem could be? eSpares sell a new water pump for around £25, and to save money, am thinking about replacing it myself (have watched a couple of videos on how to do it). Has anybody had the same problem with their washing machine? Thank you.
Sophiasky Avatar
2y, 4m agoPosted 2 years, 4 months ago
Options

All Responses

(11) Jump to unreadPost an answer
Responses/page:
#1
may want to give the model number to aid ppl in assisting you
#2
mattmerch
may want to give the model number to aid ppl in assisting you

This is what is on the front of the machine - Beko 7kg 1600 rpm, WME7267W. Thank you.
#3
i'm having a similar issue with my hotpoint , it will do the wash cycle , then die so i turn off at the mains and on again and start on a rinse and spin then it dies again .

we have cleared the filter and it pumps water in and out fine , our problem is the pcb , the circuit board and is going to cost more to repair in parts and labour than a new machine , so i'm looking for a new machine now :( .
#4
It's probably the little plastic pieces that's are stuck the the pump.

if you know anyone who is competent enough to try it let them have a go fixing it.

It's really simple. open the back case take top of and pump should be at the bottom it's got hose clamps on it.
#5
run it in test mode to see if it gives you any clues
To do that first turn the power off and then turn the dial to 90 cotton.

Press and hold the start/pause button and switch on.After 3 secs the start button will flash.
Each push of the start button will test a different function of the machine. There are 12 in all.
An error will be displayed on the function that doesn't work.

"some of the plastic pieces inside snapped off" if you mean the the fins on the pump you will need a new pump but remember espares are not cheap


Edited By: terry7866 on Jul 31, 2014 16:13
#6
You still have something stuck in the pump filter, twist the cover off again and stick your finger in..... sometimes there can be pieces of material stopping it spinning freely.

Also check the water drain hose isn't blocked, this is the hose that connects under your kitchen sink.

Edited By: transit on Jul 31, 2014 17:26
#7
got home after posting on this thread and my washing had done the same thing refusing to drain and just giving an error code U11
had to clean the filter (completely full of fluff )
#8
Would like to thank everybody for their advice over this. Got back from holiday and took a chance that it was the washing machine pump filter, so ordered one from espares for £23.99. Watched a video with my son on youtube showing how to replace a Beko pump filter and he managed to change it over (took about 20 minutes in all). So pleased to find that it actually did the trick - washing machine now working perfectly and have saved myself a lot of money by not having to get a professional out to do it. Thank you.
#9
well done, great feeling isn't it :)
#10
bluetba
well done, great feeling isn't it :)

Yes. I was going to scrap our tumble drier and get a new one, as it isn't drying the clothes very well - does the cycle but the heat used is only slightly warm and no longer hot. Will ask again on here for advice about it and then see if it appears to be a straightforward thing to fix (perhaps replace an element or something), if it is, will see if I can order the part needed for it again from espares. Thank you.
#11
now get it insured.

Post an Answer

You don't need an account to leave a response. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!