Western Digital Elements 500GB External HDD from Play.com - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit
The Elements USB 2.0 external hard drive is a fast, easy, reliable way to add more storage to your PC or Macintosh. Simply plug it in to a USB port and start saving or backing up your photos, music video and files. It's pre-formatted for immediate use. The compact, durable metal case provides extra data protection.

Free Delivery as standard from Play.com

I realise this gets not great reviews, but it seems an OK price if you need the storage. and Play are pretty reliable for me.

Quidco available, but I think only saves about 50p....
×
Get the Hottest Deals Daily
Stay informed. Once a day, we'll send you the deals our members voted as the best.
Failed
McGeezer Avatar
7y, 11m agoFound 7 years, 11 months ago
Options

All Comments

(7) Jump to unreadPost a comment
Comments/page:
#1
Actually forget this. Play also have the Buffalo 500GB for same price, and that gets much better reviews...
banned#2
disappointed !

winterfield | 15/12/2008 | See all winterfield's reviews (1) »

It was good while it lasted, barely a year.now it wont work & all my files are locked in, unless anyone knows how to retrieve them? The thing just died, no power getting to it, not sure if it is power cable or something else,anyone have any ideas ?

1 of 2 people found this review helpful. Did you?Yes | No | Report abuse
Customer rating: 1 out of 5 stars The AC Adapter died too soon

MsMutley | 25/11/2008 | See all MsMutley's reviews (1) »

I loved this, when i first got it. It didnt travel it just stayed here. Storage was fast and great. I got loads on there.
Trouble is I cant get anything off now.
The adapter flashes green when you first plug it in and thats it, no more.

Is there anyway just to buy a adapter?

1 of 1 people found this review helpful. Did you?Yes | No | Report abuse
Customer rating: 1 out of 5 stars It appears the ac adapter is wrecked.....

JonnyBoy1980 | 21/10/2008 | See all JonnyBoy1980's reviews (1) »

.......which means all of my files are stuck on the hard drive and im not sure how i go about getting a new adapter to see if this is really the problem. The little green light doesnt come on when i plug the ac adapter into the mains which makes me think that it is the adapter that is the problem.

My main issue now is if I buy a whole new hard drive just so that i can get a new adapter and it turns out it is the hard drive itself that is wrecked it means I have lost all of my files and wasted another load of money on it......

dont know what to do!!! I think with these things you get what you pay for - in future i will be backing all my stuff to another hard drive....and not using a Western Digital one

2 of 2 people found this review helpful. Did you?Yes | No | Report abuse
#3
Beware WD RMA service is appalling atm I sent a 500gb internal in special delivery 9th Dec hasn't even be logged on the system yet and RMA number expires on the 7th Jan.
#4
I've RMA'ed drives with WD several time sin the past. always been a fast turnaround and good CS for me.
#5
Well its rubbish atm which is what counts.
#6
Klyken
Well its rubbish atm which is what counts.


My last RMA with WD was just a few weeks ago. I had to post the failed drive to their forwarding centre at gatwick. they confrimed receipt within a day and forwarded it on to their overseas RMA centre. My replacement drive turned up about a week later.

Seems to me you've just been unlucky.
#7
Judging by the forums I've been on you must of been lucky this has been happening on drives sent up to 2 months ago. I sent it in special delivery there's an apparent signature of sorts for it, but it must be in a dark corner somewhere no one has answered my query about the RMA number expiring either.

Still it could of been worse I'd be sweating instead of seething if I'd done the 'Advance RMA' with a few more days before the $220 hold over charge appeared on my credit card.

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Top of Page
Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!