[BUG]: Removal of first item in "Saved Deals" redirects to another page - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

All Comments

(6) Jump to unreadPost a comment
Comments/page:
#1
Title: "[BUG]: Removal of first item in "Saved Deals" redirects to another page"

Topic: "Other"

Without expanding the "Saved Deals" list to see all entries ("View All") I clicked the [x] icon to the right of the first "Saved Deal" item within my Profile [activity] tab.

This action resulted in a redirection to the following address:

[ http://www.hotukdeals.com/widget?w=saved_threads&action=saved_thread&st=delete&td=902921 ]

The text on this page was:
---
success
SUCCESS_SAVED_THREAD_REMOVAL_SUCCESS
---

I was expecting the entry to be removed from the list & to remain within the [activity] tab as occurs when deleting items from the "Subscribed Threads" list.


However, when I expanded the list & clicked the [x] icon next to another item in the list a prompt ("Are you sure you want to delete?") was displayed. On confirming my intention with the [OK] button (rather than the [Cancel] button) the item was removed & the [activity] tab remained as originally expected.

Clicking "Collapse" to shrink the list within the page & deleting another entry in the "Saved Deals" list then functioned as originally expected.

PS. Adding tags during the creation of this thread also did not work. None of the three tags I added were displayed.

BFN,

fp.
[admin]#2
Can you duplicate this issue again? I just attempted it, and the page performed as expected. Let me know, thanks : ).
#3
DevelopmentTeam
Can you duplicate this issue again? I just attempted it, and the page performed as expected. Let me know, thanks : ).


No... but that may be because of a certain set of conditions in effect at the time of the incident.

Is the text I relayed at the time something that you can check within your programmatic code to see how/when it is displayed? Or even the redirection address?

This aside, whilst trying to reproduce the issue for you now (some days after I first reported the problem) I managed to produce the "Are you sure you want to delete?" prompt (that I answered negatively to) but on a subsequent use the prompt was not displayed. The second time the entry in the list was deleted without being prompted.

BFN,

fp.
[admin]#4
Thanks for the help. This is being looked into as well as many other things.
#5
DevelopmentTeam
Thanks for the help. This is being looked into as well as many other things.


:) Thanks.

Good luck!

BFN,

fp.
1 Like #6
This should be fixed, as of yesterday. Good eyes, citizen.

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!