32" LCD Samsung TV Help - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

32" LCD Samsung TV Help

Mansfield193 Avatar
7y, 1m agoPosted 7 years, 1 month ago
Just switched on tv this evening and i have noticed i have green fuzz where the screen shows white or yellow. Does the same on both Satalite chanels and when i put the ps3 on.

Any one know of a cure for this.

All the best
Other Links From Samsung:
Mansfield193 Avatar
7y, 1m agoPosted 7 years, 1 month ago

All Comments

(10) Jump to unreadPost a comment
yeh, always get a sony

what cables are you usin?
no idea, but you will probably get good advice on avforums.com
easy cure for this, give me 5 mins i will tell you...............................
Yeah, just as i thought, after doing some research I found that monkeybrains is right, Always get a sony.
Scart on sat, HDMI on ps3 was working fine upto this evening.
Scart on sat, HDMI on ps3 was working fine upto this evening.

borrow some cables of your mate or sumthing and see if there a fualt with the cable- it does happen

if its not the cables then no idea
Have you put anything magnetic near to the tv, Sometimes that can cause that cant it?
Sounds to me like the scart has pulled half way out at one end. Reseat the scart cable at both ends. If that doesn't help then replace the scart cable, If that doesn't fix it then it's may be an electronic failure in either the TV or the sat box.

Another thing to check is that the TV input settings match what is connected to the scart input. You probably have a choice of RGB, S-Video and composite settings in the menu system on both the TV and sat box. Check that they match in case some little darling has been playing with them. Surprising how often this happens in my house.

Since it has HDMI then there is a high probability it isn't a CRT TV. Magnetic fields don't affect LCD or plasma televisions.

Buy a Sony if you want. You'll be paying a premium and getting nothing for it (just my opinion!)
Some kind of static probably. Untangle all your cables. Switch off for a few minutes. connect one cable at a time and test. good luck.
Well i unplugged the Tv last night , came down this morning plugged and switched back on no green fuzz, very strange as i unplugged everything and inserted everything last night and it was still there, but with the tv being switched of for a few hours and its back to normal, so fingers crossed it stays like that.

Thanks for your help anyway.

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!