Any car mechanics here? - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

Any car mechanics here?

qazim Avatar
7y, 4m agoPosted 7 years, 4 months ago
--------------------------------

Hello

I got a 97" plate 306 I accidentally put a 10amp fuse instead of a 5amp fuse in F2 which is for:

"Instrument panel warning lamps, tachometer, fuel gauge, coolant thermostat, selector lever light (auto.)
"

As the Instrumental panel stopped working.

The car turned off stright away after I started the car with the 10AMP fuse.

What have a done to the car? What parts needs replace, have oher fuses blown?

Will it be a cheap repair?

Thanks1
Tags:
Other Links From Here:
qazim Avatar
7y, 4m agoPosted 7 years, 4 months ago
Options

All Comments

(10) Jump to unreadPost a comment
Comments/page:
1 Like #1
You tried simply putting in a 5 amp fuse again?
#2
The car was working fine with the fuse blown, just the instrument pannel wasnt working (the speed, petrol meter, and car temp) wasnt working. Everything else fine, I havent got a 5AMP fuse will buy one tommrow and see if it works. As the car was working fine with the fuse blown, I dont think replacing it will fix it.

I no nothing about cars apart from car audio but i think I blown:

Another fuse,
or
Starter plugs

oh god im stressed!
#3
qazim
The car was working fine with the fuse blown, just the instrument pannel wasnt working (the speed, petrol meter, and car temp) wasnt working. Everything else fine, I havent got a 5AMP fuse will buy one tommrow and see if it works. As the car was working fine with the fuse blown, I dont think replacing it will fix it.

I no nothing about cars apart from car audio but i think I blown:

Another fuse,
or
Starter plugs

oh god im stressed!


Tbh just sounds like your over powering the dash.

Would be suprised if it doesn't fix it.
#4
In theory having a higer amp wil blow "Instrument panel warning lamps, tachometer, fuel gauge, coolant thermostat, selector lever light (auto.)
"

as thats what the fuse was for, But i dont see how any of them are designed to start the car. Lets hope somone on this forum can help me!
#5
Possibly by putting in too high a fuse you've melted the wiring behind the dash or elsewhere, probably an earth wire.
#6
Yeah but wouldnt the car still start? It sounds like its just not sparking!
#7
Two words that should never be mentioned together : French and Electricals Seriously, not a good pairing :lol: Wiring is bound tightly together so if one wire melts it can take half the loom with it. Do the dash lights work now?
#8
qazim
Yeah but wouldnt the car still start? It sounds like its just not sparking!


Not sure as dont have a 306, but one would expect the immobiliser wiring to be on that circuit so if it has damaged the wiring then it wont then start.
#9
^^

Thanks

Yeah Ill check fuses tomorrow.
banned#10
If the fuse blew then there was too much current going through it, by putting in a larger fuse you allowed that current to go straight to the dash and other electricals blowing what the fuse was protecting.

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!