car fuses - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

car fuses

RadialOne Avatar
7y, 1w agoPosted 7 years, 1 week ago
anyone know whether a peugeot 207 would take a normal blade fuse or mini blade fuse
Tags:
RadialOne Avatar
7y, 1w agoPosted 7 years, 1 week ago
Options

All Comments

(15) Jump to unreadPost a comment
Comments/page:
#1
open the fuse cover and take a look
#2
i have. i was wanting to order off halfords website and there are normal ones and mini ones. was hoping someone might know
#3
miniblade.
#4
Also is it the screenwash fuse that's gone?
#5
yeah it is
1 Like #6
It's a pretty common 'fault' especially in these conditions. Defo miniblade though..
#7
Hopefully it saved your motor :)
#8
yeah i had been reading up on it, cheers m8. unfortunately every halfords near me doesnt have any left. you wouldnt know anywhere that would do them??
#9
poundland do them
#10
mcfallg
yeah i had been reading up on it, cheers m8. unfortunately every halfords near me doesnt have any left. you wouldnt know anywhere that would do them??


try your local garage, they should hold stock of them.

All the cars I've mot'd this week have had all thier washer bottles frozen :x
#12
wickedteen
poundland do them


They're not miniblade one I don't think (well the ones I saw wern't)
As above try a local motorfactor or garage.

If you have to get by without screenwash for a day or so but need your window clean best to pour some hot/warm (not boiling) water on the screen and get the wipers on straight away before it has a change to freeze.
#13
yeah, mine have been frozen for the last 3 weeks or so. I could always hear the motor but no water would come through. But last few days there has been no noise at all. I switched one of fuses over and it worked a treat so will need to get one. thanks for your help guys
#14
try putting a tiny amount of antifreeze in the washer bottle, always works
#15
mcfallg
yeah, mine have been frozen for the last 3 weeks or so. I could always hear the motor but no water would come through. But last few days there has been no noise at all. I switched one of fuses over and it worked a treat so will need to get one. thanks for your help guys


Next time, be very careful with it - if you can hear it but no water is coming through then immediately stop using it and wait a while until you think it will have thawed, the motor may damage itself. At some point you went to turn it on and the motor was frozen and it melted the fuse to protect the motor - at this point you should also have left it for a while in the hope that the motor will thaw out and work again. If you keep trying to use it then you are forcing something which doesn't want to be forced.

Also get yourself some good screenwash.

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!