CoD MW2 Multiplayer - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

CoD MW2 Multiplayer

HappyShopper Avatar
6y, 4d agoPosted 6 years, 4 days ago
OK, what am I doing wrong?

Recently bought CoD MW2 and am now trying to play the multiplayer option but it is unable to find any matches.

I'm definitely signed in to XBox Live.

Any ideas why?

Had a similar thing happen when I first tried the multiplayer in CoD MW4 but that eventually sorted itself out a day later.
HappyShopper Avatar
6y, 4d agoPosted 6 years, 4 days ago
Options

All Comments

(10) Jump to unreadPost a comment
Comments/page:
#1
Does it say your NAT settings are strict? (should show in the lobby before you enter matchmaking)
#2
DragonChris
Does it say your NAT settings are strict? (should show in the lobby before you enter matchmaking)

No - It's just constantly running through the % countdown trying to find a match.

My network settings should be good as I have not changed them since I was playing CoD MW4 online a few days ago.

In fact, when I joined XBox live in mid-Dec and started playing online, I didn't make any changes to my broadband (O2) settings.

Any other ideas?
#3
What does it say then for NAT? Open, Moderate or Strict? We've had this issue before and then I realised we were strict, had to open/forward the port. (Honestly, I think this is your problem too ;) I never modified my settings either, but one day it just turns strict).

You can check by looking here:

http://oi25.tinypic.com/ve29z4.jpg


Edited By: DragonChris on Jan 14, 2011 21:54
#4
Sorry, Chris - I mis-understood your first post - I was in the matchmaking screen.

I have stepped back and NAT says Strict.

So, I need to setup port forwarding on my router?
#5
No probs dude. Yeah, that would be my suggestion, it worked for me (eventually, took me 2 goes to get it right using the O2 box)

Go to the following site: http://portforward.com/english/applications/port_forwarding/Xbox_Live_360/Xbox_Live_360index.htm

Scroll down and find your router, skip the ad then follow the instructions.

Should all work like a charm :) Let us know how you get on.

Edited By: DragonChris on Jan 14, 2011 22:03
#6
You might also want to check out dontasciime's post in this thread, as he also provided a solution (I can't confirm if it worked or not though, but the one I provided you worked for me :) )
#7
DragonChris
No probs dude. Yeah, that would be my suggestion, it worked for me (eventually, took me 2 goes to get it right using the O2 box)

Go to the following site: http://portforward.com/english/applications/port_forwarding/Xbox_Live_360/Xbox_Live_360index.htm

Scroll down and find your router, skip the ad then follow the instructions.

Should all work like a charm :) Let us know how you get on.

Really appreciate you help - I'll take a look later or in the morning and post back.

(Shame it didn't just work like CoD4 did).
#8
No problem, it can be really frustrating when this happens (annoyed the hell out of me when it did). Although I did have this problem with CoD4 I think or maybe it was MW2, can't remember, but had to do the same for our BTHomeHub at the time.

Good luck :)
#9
So, followed the port forwarding instructions, re-booted the router (just in case) and nothing.

Checked the settings and all good.

Deleted and re-did them but still no joy.

Could see no obvious reason why it wasn't working now so did a quick Google search and came across a YouTube video which recommended running the Test XBox Live Connection as, for some reason, this causes the NAT setting to go to change to OPEN.

Anyway did this and bingo, all working.

Video can be found here: http://www.youtube.com/watch?v=GFKyyAz4zj4

Once again Chris, appreciate your help.
#10
Fair enough :) I found I had to set a static ip on my pc for it to work as in instructions but as long as you got it working again, all good man!

Have tried testing connection before but never worked for me, so lucky you :D Happy gaming!

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!