Creative Zen V Plus not recognised by windows 7 - HELP - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

Creative Zen V Plus not recognised by windows 7 - HELP

agnes Avatar
6y, 5m agoPosted 6 years, 5 months ago
I've recently got a new computer running windows 7 and have just tried to use Zen Media explorer on this for the first time to add some CDs but it just says "your player is not connected". I have checked on the creative site in case I needed new drivers
http://www.tinyurls.co.uk/C6533
but the Zen isn't listed there.
Does this mean Creative are no longer supporting the Zen - any help REPPED....thanks
Other Links From Creative:
agnes Avatar
6y, 5m agoPosted 6 years, 5 months ago
Options

All Comments

(18) Jump to unreadPost a comment
Comments/page:
#1
sorry i can't help but i have exactly the same problem so i'll be keeping an eye on this
#2
Oh well, at least I know it's not just me or my computer...let's hope someone can sort us both out :)
#3
If you go to device manager is it showing up under MTP devices?
#4
have you got the latest firmware, check this site
i think thats the right player?
#5
It is showing up as a device and has a little icon saying "My Zen" so the computer knows it is there.
#6
agnes
It is showing up as a device and has a little icon saying "My Zen" so the computer knows it is there.


And it doesn't have a warning sign next to it in device manager?
#7
dungavel
And it doesn't have a warning sign next to it in device manager?


No, no warning signal
#8
Narfette
have you got the latest firmware, check this site
i think thats the right player?


Thanks for the thought - that is the right player but I have already tried that.
#9
Ok, am playing this as a bit of a shot in the dark but I have had a similar issue with a Sansa Fuze on Ubuntu but bear with me as this solved the problem for me.

Most Mp3 players have the option to set the device type to either MTP (media transfer protocol) or MSC (mass storage controller, also known as UMS). MTP can be problematic with some installations but MSC can also cause issues! (I never said this would be easy:-D ).

It is worth trying to see if your Zen has the option, in settings, to swap between the connection types and seeing if either work.

HTH

Dave
#10
i assume youve also tried resetting the player? - holding down the reset? (as long as theres no music on there already - as this will probably wipe it)

ive also just read on a forum that windows media player can sometimes interfere - do you know if you updated it recently? could try rolling back the media player - see if that helps
#11
Many thanks for all the ideas that people offered - none of them worked BUT I have now found a work around...Although I can't get the Zen V Media Explorer to work at all, you can copy CDs to the Zen in a two stage process.

Just open Windows Media Player and check the "rip settings" for the quality you want and also to save in MP3 format, then choose "Rip CD" and off it goes. Once it has finished it looks like you should be able to drag the file to "My Zen" which is shown in the player but I can't make it work. But all you have to do is open "libraries", find the CD in the Music library and you can then drag it to the Zen icon. As you hover over the icon it open up your folders and you can drop it where you want.

At least it means I can still add stuff to my Zen V but what a shame creative aren't providing new drivers for this...
#12
Ive got a creative zen touch, the bloody fun & games i had with that when they released media player 10, it stopped recognising the player, it was driving me nuts :x I had to roll back to media player 9, have you tried the creative forum ?
#13
youve got to run the software in xp mode.........

i had same problem with an old player recently, messed around for hours
#14
casparwhite
youve got to run the software in xp mode.........

i had same problem with an old player recently, messed around for hours


I did think of that but I couldn't find any place to change the compatability
#15
agnes
I did think of that but I couldn't find any place to change the compatability


right click on the programme and click troubleshoot compatibility
#16
I had the same problem. I have creative zenVplus, the ting I did is I went to Device manager, the device was in yellow, so I pressed UPDATE driver and ..... it worked, windows 7 found a driver online, and now everything works. Good luck!
#17
surfer9bg
I had the same problem. I have creative zenVplus, the ting I did is I went to Device manager, the device was in yellow, so I pressed UPDATE driver and ..... it worked, windows 7 found a driver online, and now everything works. Good luck!

what version / name etc is ur driver?
i'm using windows 7.
When i clicked update driver, it says my driver is already the most updated x.x but my player still cannot be detected.
#18
surfer9bg
I had the same problem. I have creative zenVplus, the ting I did is I went to Device manager, the device was in yellow, so I pressed UPDATE driver and ..... it worked, windows 7 found a driver online, and now everything works. Good luck!

Done! Thanks, surfer9bg! Had exactly same issue with Zen V but followed instructions above and now works perfectly.

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!