Do I have a Faulty Wii ? - Help - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HotUKDeals, you accept our cookie and privacy policy.
Get the HotUKDeals app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

Do I have a Faulty Wii ? - Help

£0.00 @
Hi Guys, I bought a Wii off ebay supposedly fully working, I've just turned it on and have no picture on the screen, also the power button stays red and the drive flash blue when I press the on button… Read More
Zootaga Avatar
banned8y, 2m agoPosted 8 years, 2 months ago
Hi Guys, I bought a Wii off ebay supposedly fully working, I've just turned it on and have no picture on the screen, also the power button stays red and the drive flash blue when I press the on button....

Am I doing something wrong or is it faulty?

Thanks
Tags:
Zootaga Avatar
banned8y, 2m agoPosted 8 years, 2 months ago
Options

All Comments

(22) Jump to unreadPost a comment
Comments/page:
#1
sounds like its faulty to me id complain to ebay saying item not described and try gettin ya momey back
#2
Is it chipped?
banned#3
drive does flash blue either went inserting or ejecting a cd, power button is red when its on i do believe?? try changing scart and make sure TV is on right AV channel
banned#4
linda turnock
sounds like its faulty to me id complain to ebay saying item not described and try gettin ya momey back


Sounds nice but it was no paypal which is why it was so cheap, they guy isn't replying...It was £70 boxed with controller and nunchuck...was advertised as working though so was hoping it was a simply fix?
banned#5
Adam2050
Is it chipped?


Don't think so, How do I check?
banned#6
gsettle24
drive does flash blue either went inserting or ejecting a cd, power button is red when its on i do believe?? try changing scart and make sure TV is on right AV channel


It won't let me insert a CD, It did originally have the Wii Sports in it which I ejected and I haven;'t been able to do anything since
#7
Zootaga
Don't think so, How do I check?


Not sure unless its already been opened though I wouldn't do that if its arrived faulty.

Sounds like a Video chip error.

I think there is such a thing as wii red light of death.

I would check the cable, as It could been set to some stupid composite cable.

Would hold down the power when you turn it on and check the cables setup correctly.
banned#8
Just tried it again, this time it powered up, but still no picture? the screen is black.....it's deffinately the right channel?
#9
Zootaga
Just tried it again, this time it powered up, but still no picture? the screen is black.....it's deffinately the right channel?


What cable is it?
banned#10
Adam2050
What cable is it?


It's the standard composite cable
banned#11
Arghh...Now when I push the power button it just makes a clicking noise and the blue drive light flashes, it doesn't power up?
#12
Zootaga
It's the standard composite cable


What TV?

I would check its correclty put in and if you have a mate borrow his cable or his tv.

Make sure its on the right AV before you go anywhere too:thumbsup:.
banned#13
Adam2050
What TV?

I would check its correclty put in and if you have a mate borrow his cable or his tv.

Make sure its on the right AV before you go anywhere too:thumbsup:.


I tried on my Samsung plasma downstaires and then my Toshiba in the bedroom, both registering a signal but the screen stays black...gonna ring nintendo..>Thanks
#14
Do the wiimotes sync up? Do you hear any sound?

It does sound as if its just not outputting at the right resolution or something. You could try a soft reset by holding the reset button 2/3 seconds, not sure if that will help.
banned#15
did it work at the geeza's house?
banned#16
Just noticed the power supply isn't a genuine Nintendo...Could it be as silly as this?
banned#17
PhearFactor
Do the wiimotes sync up? Do you hear any sound?

It does sound as if its just not outputting at the right resolution or something. You could try a soft reset by holding the reset button 2/3 seconds, not sure if that will help.


Nope they don't, although not 100% am doing it right, this is the first wii I have had so not easy without a picture
banned#18
hippoface
did it work at the geeza's house?


not sure, he posted it to me...he says it did though
#19
Zootaga
not sure, he posted it to me...he says it did though


Just whine to ebay seems like its a refit from gamestation or game.
#20
zootaga, have you any friends with wii's? maybe go to there house and try it on there channel, even try it with their power pack etc then you will definetly know if it faulty or not.
banned#21
boza
zootaga, have you any friends with wii's? maybe go to there house and try it on there channel, even try it with their power pack etc then you will definetly know if it faulty or not.


Yeah, am gonna try this out, process of illimination I guess
#22
you say it's making a clicking noise ? You also say you ejected the wii sports disc ??? have you put any other disc in ? You say you can't put another disc in it...do you mean when you try it just wont accept it...what about with a little push ?? Sounds to me like the cogs are gone on your drive and if thats the case then you would need to send it somewhere to get a new drive installed. Mine did the same thing but i could manually put a disc in but it would eject it as it would just make a clicking noise.

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!