Ericsson debranding - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

Ericsson debranding

morrk Avatar
7y, 11m agoPosted 7 years, 11 months ago
Hi guys,

I saw a guide on here a while ago regarding unlocking/debranding Sony Ericsson phones.

I've had a look around for it but cannot find anywhere.

Could somebody help me out with a link please?

Fank ewe :)
Tags:
morrk Avatar
7y, 11m agoPosted 7 years, 11 months ago
Options

All Comments

(6) Jump to unreadPost a comment
Comments/page:
#1
Google for a prog called SEUS

Then google for the product code for your phone. Use SEUS to change the code to a none branded version of your phone and connect the phone to the software that came with and tell it to upgrade the firmware and it'll upgrade to the none network version. Read the info that come with SEUS twice and upgrade once and your there. . .
#2
Seus is the Sony Update Service. I don't believe you can change the phone network ID this way.

There was quite a comprehensive guide on here a while ago that involved using 3rd party software.
#3
Sorry, engaged typing finger before brain cell...
Try here http://forums.se-nse.net/index.php?showtopic=27192
#5


Funnily enough I had a feeling it was you that posted the post I am talking about ShaneCR. :thumbsup:

I searched through your posts for quite a while earlier while trying to find it before posting this thread.

I gave up in the end as I couldn't find a free way of doing the W890i so just used davinci and working fine :)

Cheers mate
#6
morrk
Funnily enough I had a feeling it was you that posted the post I am talking about ShaneCR. :thumbsup:

I searched through your posts for quite a while earlier while trying to find it before posting this thread.

I gave up in the end as I couldn't find a free way of doing the W890i so just used davinci and working fine :)

Cheers mate


yeah. it was my post. i spammed it as the links i had went bad and i could find replacements. So rather than put up with the constant pm's i was getting (i couldnt help!! i couldnt find new links!!) i spammed it and it disappeared.

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!