Geforce XFX 9500GT Alpha Dog Edition - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HotUKDeals, you accept our cookie and privacy policy.
Get the HotUKDeals app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

Geforce XFX 9500GT Alpha Dog Edition

£0.00 @ GeForce
Hey, formatted my pc and installed vista with sp2 retail. Everything went fine apart from when i try to install a nvidia driver i get a black screen upon startup. It just stays black and graphics card… Read More
vir3us Avatar
7y, 10m agoPosted 7 years, 10 months ago
Hey, formatted my pc and installed vista with sp2 retail. Everything went fine apart from when i try to install a nvidia driver i get a black screen upon startup. It just stays black and graphics card is noisy. Used to be fine, dont know what the problem is? It can load up but has the standard vga driver, but that is no good. Any help i would be gratful. Thankyou
Other Links From GeForce:
vir3us Avatar
7y, 10m agoPosted 7 years, 10 months ago
Options

All Comments

(21) Jump to unreadPost a comment
Comments/page:
banned#1
Got another PCI-e slot to try it in? otherwise it's got lifetime warranty so just open an RTA with them or take it back wherever you bought it from. PC world swapped my old 8600GS Alpha dog for a 9600GT :thumbsup:
#2
Yh got 2, it is sli but only have 1 of these cards. Was gonna update the bios but the utility said I/O was different than wanted or something like that, said it could damage it if i continued so i didnt bother. Did you get it from pc world? got mine from Ebuyer. Cheers lumoruk
#3
Did you use the driver on the CD supplied with the card or the latest from NVidia's website? If it was the CD version you will probably need to get the latest one from the web.
#4
Spod
Did you use the driver on the CD supplied with the card or the latest from NVidia's website? If it was the CD version you will probably need to get the latest one from the web.


Yh tried the CD but i cannot install anythink from it, says goto nvidia's website to get the latest drivers. So i did. But none of them seem to work now :? emailed the guy on xfx website with my problem. Couldnt update the bios on graphics card before, but done it now. Hopefully that will make the nvidia drivers support my card better? Not sure what it did.
#5
Do you recon its anything to do with SP2. What if i install vista without any packs then update the graphics card driver then try it, then install service packs. Done the bios update fine this time but still the same. Will it make any differance do you think? Hav'nt tried the other PCI-E slot yet.
banned#6
does it show the BIOS screen fine?
#7
lumoruk
does it show the BIOS screen fine?


The motherboard bios? when i load up pc and press Delete. Yh no problem
banned#8
vir3us
The motherboard bios? when i load up pc and press Delete. Yh no problem


Tried safe mode which will load generic drivers for your video card?
#9
Yh but their s***. I want my resolution at 1920x1080 but cant :x
banned#10
vir3us
Yh but their s***. I want my resolution at 1920x1080 but cant :x


what? lol you need to go into safe mode to see what you're doing (you said you're getting a blank screen). Then install the latest drivers from nvidia.
#11
Have done lol, latest drivers do not work atall.
banned#12
vir3us
Have done lol, latest drivers do not work atall.


You selecting the right drivers? sounds like you've downloaded the wrong version
#13
lumoruk
You selecting the right drivers? sounds like you've downloaded the wrong version


Yeah im sure

Version:

190.38 WHQL
Release Date:

2009.07.21
Operating System:

Windows 7 64-bit, Windows Vista 64-bit
Language:

English (UK)
File Size:

135 MB
banned#14
stupid question I know sorry you're running 64bit vista? odd choice if you are btw why did you choose 64bit vista?
#15
Y not lol it's the way forward

AMD Athlon 64 X2 6000+ 3GHz
Gigabyte GA-M57SLI-S4
OCZ Stealth Xtream 500W PSU
OCZ 4GB (4x1GB) DDR2 800MHz/PC2-6400 Platinum XTC
XFX 9500GT 680MHz Edition 256MB DDR3

Do you use 32bit?
banned 1 Like #16
vir3us
Y not lol it's the way forward

AMD Athlon 64 X2 6000+ 3GHz
Gigabyte GA-M57SLI-S4
OCZ Stealth Xtream 500W PSU
OCZ 4GB (4x1GB) DDR2 800MHz/PC2-6400 Platinum XTC
XFX 9500GT 680MHz Edition 256MB DDR3

Do you use 32bit?


32bit on a 64bit processor yeah, will be using 64bit windows 7 when it comes as Windows only using 3.3Gb of my 4Gb RAM

i've run out of ideas, I'm 75% it's not hardware though. Put your BIOS settings on default?
#17
I could try the 32bit maybe it might work, dont know ;-). Want windows 7 but when installed goes to startup and get the black screen. Cheers for your help though matey.
#18
Got the latest motherboard bios and the graphics card bios. reinstalled vista x86 with no service packs, installed fine and loaded up. Done all windows updates so far. For some weird reason my pc isnt reconizing the graphics card. Comes up as generic non-pnp monitor on standard vga graphics adpator in display settings. is there a way to reset my graphics card bios to back to factory defult? tried the drivers from here but they do the same. If i update the card in device manager it install the latest one which doesnt work for me. Cheers
banned#19
vir3us
Got the latest motherboard bios and the graphics card bios. reinstalled vista x86 with no service packs, installed fine and loaded up. Done all windows updates so far. For some weird reason my pc isnt reconizing the graphics card. Comes up as generic non-pnp monitor on standard vga graphics adpator in display settings. is there a way to reset my graphics card bios to back to factory defult? tried the drivers from here but they do the same. If i update the card in device manager it install the latest one which doesnt work for me. Cheers


You would need to get hold of an original graphics card BIOS to flash it again, never flashed my graphics cards BIOS though so wouldn't know where.
#20
Oh right, maybe if i ask XFX they might send me it? Cheers
#21
Everything is good now. Just cant update graphics driver after 178.24

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!