Help 3 of my usb ports wont recognise devices - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HotUKDeals, you accept our cookie and privacy policy.
Get the HotUKDeals app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

Help 3 of my usb ports wont recognise devices

£0.00 @
they either say uknown and malfunctioned, or they dont say anything at all when i add any type of usb device, and they dont appear in device manager is there anythin i can do? Read More
dark_like_vader Avatar
7y, 11m agoPosted 7 years, 11 months ago
they either say uknown and malfunctioned, or they dont say anything at all when i add any type of usb device, and they dont appear in device manager

is there anythin i can do?
Tags:
dark_like_vader Avatar
7y, 11m agoPosted 7 years, 11 months ago
Options

All Comments

(8) Jump to unreadPost a comment
Comments/page:
banned#1
Go into device manager and delete the usb ports, Close down and reboot, when it initialises it will add the new hardware found again. This usually sorts out problems of this kind
#2
sculpturatus
Go into device manager and delete the usb ports, Close down and reboot, when it initialises it will add the new hardware found again. This usually sorts out problems of this kind


+1
#3
MY ports died on my pc and i had to get a pci card with 4 ext and 1 int cost me £11 from nova tech all working now and it reconizes my usb hub and external devizes again
#4
Seen this happen lots of times , when folk just pull their flash drives/pendrives/external drives .etc .etc out of the ports without closing them down first .For some reason it can disable the USB ports . Not sure if this has been the reason in your case ,but try the above method or buy a USB PCI card .
#5
ye ive tried deleting the ports in device manager and it hasnt fixed it, i think the only thing i can do is reinstall windows which i really dont want to have to do

ive reinstalled the motherboard drivers and thats not fixed it either
#6
This happened to me and I did a system restore to when they were working ( Ie 24 hours before) and this seemed to work - no more problems so far - touch wood.
#7
ive tried a system restore and still no luck, infact ive thrown everythin i can at it
reinstalled drivers, disabled usb in bios,
it seems that the drivers for the usb controllers are not installed

http://i42.tinypic.com/16ao56p.jpg
#8
THIS IS WHAT MINE CAME UP WITH TRY A PCI CARD FOUND THIS ON PLAY.COM http://www.play.com/PC/PCs/4-/3274156/Belkin-Hi-Speed-USB-2-0-5-Port-PCI-Card/Product.html THERE IS 1 ONPLAY TRADE FOR £6 APPROX

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!