Help - car seat belts not sliding back into place - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

Help - car seat belts not sliding back into place

JACK10 Avatar
8y, 4m agoPosted 8 years, 4 months ago
Does anyone know how to solve the problem of car seat belts not sliding back into place.? I have a Ford Galxy. It is really getting on our nerves that we have to twist round & feed the belt back up manually.
Other Links From Seat:
JACK10 Avatar
8y, 4m agoPosted 8 years, 4 months ago
Options

All Comments

(11) Jump to unreadPost a comment
Comments/page:
#1
garage job - happened to 0/h only other way round -
#2
Pull them ALL the way out to make sure they're not twisted. If the problem is still there you may need replacements as they're MOT failures.
#3
Pull it out mate a few times & it should be back in place & if it doesnt work that way, please visit the garage..
#4
I've heard about this problem on other forums. People suggested the following:

Pull the seat belts out and fasten them into the buckles (or whatever it is called), wash with soapy water and make sure they they have dried completely before letting them recoil (otherwise they will smell of damp).

That should solve the problem, let us know if it works.
banned#5
Crash your car and see if the tensioners are still operating, if they are then probably just a simple tangle inside the housing.
#6
You have knacked springs in your seat belts go to the breakers to get replacements a lot cheaper then the dealers. :thumbsup:
#7
We have had this a couple of times, it usually means a new belt, which as someone already said you can get from the breakers. Much cheaper than a dealer. Good luck.
#8
i had this once was told to yank really hard on them and would jolt back into operation worked for me
#9
Thanks guys, I'll put your advice to the test tomorrow.:roll:
#10
we've got a galaxy and ours does the same.design fault?
#11
underthestairs
we've got a galaxy and ours does the same.design fault?


no just poor ford quality

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!