Help needed from the mechanics out there!! - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

Help needed from the mechanics out there!!

jayhab Avatar
9y, 8m agoPosted 9 years, 8 months ago
Help!!

The heating in my car has busted. For about a week it did nothing but blow hot and then from 2 days ago all it will do is blow freezing cold air!! - Right in time for the cold spell!!!

It's a Ford Puma by the way - has anyone had experience of this before, or knows exactly what part has busted?

I've looked in the manual incase it's a fuse - but it doesn't look like it is - the same fuse serves the radio too, which is fine.


Any help will be gratefully received!!!


Thank you
:-(
jayhab Avatar
9y, 8m agoPosted 9 years, 8 months ago
Options

All Comments

(12) Jump to unreadPost a comment
Comments/page:
#1
Any liquid seeping into the foot wells ?

How old is the car ?
#2
has your car got air con if so then your aircon need's re-gassing by the sound's of it as the same happened to my car a while ago
#3
jayhab
It's a Ford Puma by the way


I see your problem! :lol:

Honestly, I haven't a clue....sorry. Hope you get it sorted!

You a hairdresser by the way?
#4
nothing seeping into the footwells and no aircon - it's 8 years old this year.

Birdyboy - strange how your right-hand powerball score is so much higher than your left hand..
#5
birdyboyuk
I see your problem! :lol:

Honestly, I haven't a clue....sorry. Hope you get it sorted!

You a hairdresser by the way?


But... but... the advert was awesome!
http://www.youtube.com/watch?v=iAlklV5TZrE
#6
jayhab

Birdyboy - strange how your right-hand powerball score is so much higher than your left hand..

I polish the car a lot :thumbsup: :giggle: :whistling:
#7
could be a broken thermostat in the cooling system.
#8
i'd actually forgotten the puma advert featuring steve mcqueen - i only bought one after playing Colin Macrae on the Playstation!!!

But back to the point - any other ideas on what's wrong?

edit-

currychops - i thought that as soon as it started blowing just hot air - that sounds as though it could be expensive?!?!
#9
Summer soon, get it repaired just before winter kicks in
#10
- done some digging - possibly the heater control valve?
#11
it could be an airblock in the pipes or check your water or i could be the water pump.
#12
esims - yes it could be an airblock in the pipes - not sure about the water pump tho' - everything else is still ok i.e. the dash temp gauge still starts off cold and during a journey rises to where it always used to...
lots of sites are pointing to the heater control valve and quote my symptoms exactly - the only hot and the only cold air - apparently it's a very common fault on pumas and fiestas?

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!