Help please, cant access my slave hard drive. - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

Help please, cant access my slave hard drive.

mrfun1981 Avatar
8y, 3m agoPosted 8 years, 3 months ago
Need some help please,

Yesterday i was suckered in to opening a attachment that come with a email, which filled my PC up with a load of crappy virus's & spyware.

Im used a combination of NOD32 & AVG to clear up my PC & they are now saying that that PC is clean. But im longer able to open up my slave drive it asks me what programme i want to use to open the hard drive with.

The only programme i know that would prob do this is "explorer.exe" but this doesn't open the drive up.

I still believe all the files are in one piece on that drive because the anti virus software can still scan the hard drive + Utorrent can still do a force re-check on that drive ok.

So dose anyone have any ideas how i can gain access to my slave drive please

Cheers
mrfun1981 Avatar
8y, 3m agoPosted 8 years, 3 months ago
Options

All Comments

(21) Jump to unreadPost a comment
Comments/page:
#1
Right click my computer;
manage;
disk management

Check that it is still assigned a drive letter in there
#2
Done that & the drive still got the same letter that it was assigned before
1 Like #3
What operating system are you using?
#4
Im using XP
#5
What happens if you right click the drive and select open?
banned#6
didnt AVG detect the viruses?
#7
http://img292.imageshack.us/img292/7843/53418053pj7.th.png

Here is a picture, i know its not that big im not that good at this sort of thing,

Iv just been having a play with "tuneup" as that as got a disk explorer option on there, i can gain access to the files on my slave drive & even play the music on it.

But i still cant access the slave drive via my computer. So im guessing that the virus may for affect some of the windows software.

@csiman

Call it being stupid iv not had anti virus software on my PC for nearly a year & iv not had any problems, Think iv learnt my lesson now :oops:
1 Like #8
The problem is that the virus / Trojan thing you had has re written your autorun, then when you done the virus check it deleted the autorun leaving that drive with no valid autorun file hence the open with box

As for solutions there are a few options, i've never tried them so can't guarantee they will work but here they are;

run these 2 DOS commands:

C:\>attrib -S -H -R C:\autorun.inf

C:\>del /F C:\autorun.inf

then repeat the procedure with:

D:\>attrib -S -H -R C:\autorun.inf

D:\>del /F C:\autorun.inf


or a longer one;

Choose the program you want to use to open this file with:

In this case, the “Always use the selected program to open this kind of file” option is grayed out.

The symptom occurs because when autorun.vbs is created by trojan horse or virus. The virus normally loads autorun.inf file to root folder of all hard drive or USB drive, and then execute autorun.bat file which contains script to apply and merge autorun.reg into the registry, with possible change to the following registry key to ensure that virus is loaded when system starts:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Userinit=userinit.exe,autorun.exe

Finally, autorun.bat will call wscript.exe to run autorun.vbs.

When antivirus or security software detected the autorun.vbs file as infected, the file will be deleted or removed or quarantined. However, other files (autorun.*) and registry value still referring to autorun.vbs, and this document no longer exists, hence the error when users double click to open a drive folder.

To correct and solve this error, follow this steps:

1. Run Task Manager (Ctrl-Alt-Del or right click on Taskbar)
2. Stop wscript.exe process if available by highlighting the process name and clicking End Process.
3. Then terminate explorer.exe process.
4. In Task Manager, click on File -> New Task (Run…).
5. Type “cmd” (without quotes) into the Open text box and click OK.
6. Type the following command one by one followed by hitting Enter key:

del c:\autorun.* /f /s /q /a
del d:\autorun.* /f /s /q /a
del e:\autorun.* /f /s /q /a

c, d, e each represents drive letters on Windows system. If there are more drives or partitions available, continue to command by altering to other drive letter. Note that you must also clean the autorun files from USB flash drive or portable hard disk as the external drive may also be infected.
7. In Task Manager, click on File -> New Task (Run…).
8. Type “regedit” (without quotes) into the Open text box and click OK.
9. Navigate to the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
10. Check if the value name and value data for the key is correct (the value data of userint.exe include the path which may be different than C drive, which is also valid, note also the comma which is also needed):

“Userinit”=”C:\WINDOWS\system32\userinit.exe,”
If the value is incorrent, modify it to the valid value data.
#9
I do know some things about PC's but this is a little above my level, i always try & keep out the dos commands etc

Im not 100% sure about trying them incase i make things worse, i might be ok doing it if anyone else has done it in the past & not messed there PC up any further.

Do you know if this would slove the problem:

Back up any data i need of my master drive & do a complete re-install of windows. Would windows then be able to open my slave drive then? Its something i would feel safer doing as i know i wouldnt risk losing the data on my slave drive

Thanks for your help rep added :)
#10
Completely re installing windows would solve it yes, there are easier methods to go down though

A system restore may fix it
Also assigning it a different drive letter may do it

Try those two first
#11
HELP!!!!!

Iv done a system restore, and its made things worse!!!!!

None of my desk icons come one, the start menu dont come up, iv got no system tray. iv got nothing at all!!!
The only way iv got FF back on was to get task manger on & run FF from that.

I need to load up system restore some how & change it back.

HELP SOMEONE PLEASE????
#12
Update:

Iv found the system restore exe, i got that to load up via run in task manager. Tried restoring it back to how it was before i did a system restore earlier. but things have not improved iv still not got no start menu, system try or desk top icons!!

IV got 50GB of data on my master drive that i need to try & save some how.


Dont sure what im going to do no!!!!

HELP PLEASE
banned#13
mrfun1981
None of my desk icons come one, the start menu dont come up, iv got no system tray. iv got nothing at all!!!


These are all the signs of `explorer.exe` failing to load, missing or corrupt.

Rest assured whatever data you had on the drive is still there it's just that Windows is obviously not in great shape.
#14
I was starting to think that, but how do i solve this problem. i dont want to end up reformatting & losing all my data
banned#15
Good question...

Bring up Task Manager (hold Ctrl + Shift + Esc) and have a look for `explorer.exe` in the "Processes" tab, if it's not there go to File->New Task and type it in then click OK..

If it appears in the process list but nothing else happens or if it's already in the list then it's likely corrupt.
#16
Explorer.exe had not been working so i googled exeplore.exe missing & cam across this site & download the programme in post 8

http://www.geekstogo.com/forum/explorer-exe-missing-t86202.html

Explorer.exe is now working, but im back to square one, in the sense i cant access my slave drive via my my computer.

Think the best thing to do now is to back up the most important things on my master drive & then reformat it an put a clean install of windows on it
banned#17
As long as you're confident that you'll be able to put Windows back on (have CD + key ready) :).

I've never had this particular problem before so.... by the way instead of double clicking on D: try right clicking the drive then selecting Explore.
#18
It sounds to me as if you computer is still infected and the virus / trojan has embedded itself everywhere, run a virus scanner again, make sure that your virus definitions are fully up to date, also run a separate malware scanner
#19
Used a maleware scanner said it found something but couldnt remove it & said try using a anti virus software,

Been running AVG for the last 20mins & all its found is some tracking cookies, im actaully hoping it will find something & delete it so i know the problem is sorted out. If it dont find anything major im not sure there is anything else i can
#20
Update:

Finished the virus scan, found 8 infected files it moved/healed 6 of them, couldn't do anything with the other 2 but let me manually delete them.

Off to relax & watch the footie now, then have no choice but to reformat as i still dont have any access to my slave drive
#21
Got the exact same problem here.......... but no solution as yet

think format is the road we are looking at.

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!