Help-Xbox 360 won't turn on! - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

Help-Xbox 360 won't turn on!

that0nehurts Avatar
6y, 3m agoPosted 6 years, 3 months ago
All i did was play a bit of Rock Band then moved the xbox to a different room- Help please!
Tags:
that0nehurts Avatar
6y, 3m agoPosted 6 years, 3 months ago
Options

All Comments

(48) Jump to unreadPost a comment
Comments/page:
Page:
1 Like #1
Plugged in?
#2
Yes
1 Like #3
put it in microwave for ten minutes on full power to recharge it
1 Like #4
Is the orange light on on the power brick?
1 Like #5
wickedteen
put it in microwave for ten minutes on full power to recharge it


X)

Have you checked if the power plug is in correctly in the back of the 360 and on the brick? Is there a switch on the brick (can't remember) and is it turned on?
1 Like #6
lol basics
1 Like #7
Try connecting it to the same place as it was before & see if that works. If now try changing the cable that connects to the powerbrick & the socket. Just to make sure that the fuse is not gone. You can use normal kettle cable for it
#8
Orange light is on
1 Like #9
If thats the case than make sure its properly connected to XBOX.

The power supply light is orange for one of the following reasons:

* The console is turned off.
* The power supply is not plugged into the console or the connection is not tight.
* The power supply is not functioning properly.

Note An orange light usually indicates that the power supply is connected to electricity and ready to power the console. When you turn on the console, the power supply light should change from orange to green

Edited By: IrfanFaruki on Sep 03, 2010 14:40: Added More Info
#10
It is.
1 Like #11
that0nehurts
It is.


It is what?
#12
It is plugged into the xbox
1 Like #13
Are you connecting it to a socket using a multiplug connector? if so try connecting it just by itself.
#14
Nope, not working by itself either
1 Like #15
Does the console do anything when you try and turn it on?
#16
Nope
1 Like #17
if this is brand new xbox than i would take it back to the store.
1 Like #18
Well if the power is plugged in to the console and the power brick light is on then something must be physically broken. Be it the power switch on the front of the console of the cable going from the powerbrick to the console.

Have you tried turning it on using a controller rather than the front button?
#19
Yes i have tried that, didn't work tho, had it more then a year so can't take it back :(
1 Like #20
Got a friend with a xbox so you can try parts? Try your PSU with their console and your console with their PSU. See which (if either) is faulty.
1 Like #21
does any of your mate have xbox ? If so i would try starting it up using their power brick. May be something is wrong with the cable between power brick & xbox.
#22
Ok i'll try that- rep given to all that have tried helping
#23
Doesn't work with there's either
1 Like #24
Call Microsoft :)
Or if it´s less than a year old take it back to the shop you bought it at and get a replacement.

Edited By: TanyaSpace on Sep 03, 2010 16:55: -
#25
Had it almost 2 years
1 Like #26
that0nehurts
Had it almost 2 years


You get 3 years Microsoft cover (for certain things anyways), get on the site and have a look!
#27
For RRoD that is.
#28
Yes 3 RLOD and E74.
#29
I have neither tho
#30
that0nehurts
I have neither tho


Worth belling them up or emailing them tho, I know of a couple of people who have had fixes done free of charge by them
#31
But my xbox is flashed :(
#32
buy a new 1 in cash from tesco swap it over tell ur mum to go get a refund for it problem solved :)
#33
that0nehurts
But my xbox is flashed :(


d'oh!
#34
Have you tried pulling the power cable from the back and pushing it back in again to make sure it is fitted correctly, also is the HDMI (or whatever) connected to the TV. If you power on the console with no TV connection I don't think the front lights up properly.
#35
Ungreat - Sep 04, 2010 10:42
Have you tried pulling the power cable from the back and pushing it back in again to make sure it is fitted correctly, also is the HDMI (or whatever) connected to the TV. If you power on the console with no TV connection I don't think the front lights up properly.
Yes tried that aswell, still nothing
1 Like #36
I had the exact same issue this time last year but wasnt sure if it was a cable or console issue.

I randomly tested it a few months later and it worked.

Not that it was much help writing that but in my case it sorted itself out.
#37
Didn't really help but thanks for giving me hope it works in a few weeks/month's :L
#38
sell it on ebay as broek and get a new one
#39
Clearly the op is hiding a vital part of the moving process.
#40
I wish i was hiding something, but i can't really describe well as i am only 13 :(

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!