Horn not working on late 1999 Zafira - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Horn not working on late 1999 Zafira

nikkiandmidgets Avatar
7y, 4m agoPosted 7 years, 4 months ago
My sisters horn has stopped working on her Zafira and its due an MOT soon. She had someone look at the wiring and they couldnt see anything so said it looks like she will have to take it into dealer for diagnostics test.

Just wondered if anyone has had same problem - think the airbag also has error about same time incase its related? Just to save some cash ont he diagnostics test as local garage had a tool but doesnt cover that makemodel of Zafira

Cheers for any adviceinfo!
nikkiandmidgets Avatar
7y, 4m agoPosted 7 years, 4 months ago

All Comments

(4) Jump to unreadPost a comment
It might be a blown fuse
Her other half and the local garage checked fuse and other basic stuff but couldnt see anything obvious. They said it would need the diagnostics test or dealer knowledge they thought.
My horn wasnt working on my clio but we changed the horn and now it works, I think the wiring was fine it was just that the horn did not work. Hope that helps!! :thumbsup:
1 Like #4
just google how to fix a horn on a Zaffira car it comes up with a few suggestions

I would go first though with the fuses.....always start there

good luck:thumbsup:

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!