Installing Ubuntu on Vostro 200 - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HotUKDeals, you accept our cookie and privacy policy.
Get the HotUKDeals app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

Installing Ubuntu on Vostro 200

£0.00 @ Ubuntu
or: Koomber does more stupid things to his Vostro 200 so you don't have to. In keeping with my usefull Vostro 200 posts (I did the earlier one about what you can upgrade it too. Which reminds me…
koomber1664 Avatar
8y, 10m agoPosted 8 years, 10 months ago
or: Koomber does more stupid things to his Vostro 200 so you don't have to.

In keeping with my usefull Vostro 200 posts (I did the earlier one about what you can upgrade it too. Which reminds me, it easily takes an 8600GT with no new power supply), I'm going to chronicle my progress in installing Ubuntu onto a Vostro 200.

23:41 At this point I've been looking through forums and IRC chat (beware Ubuntu chat room on Launch day. it will make your eyes bleed) I've discovered the reason I've not been able to get the dang thing to even boot thus far. Apparently in the bios settings you need to change the SATA control from IDE to RAID. I have no idea why this works, I only know it does. Did I mention I've been at this since 20:00? Yeah. I'm pretty tired but I'm not going to sleep till It's either installed or inflames.

So I know hoe to install ubuntu, the only problem is that since Vista was installed in IDE it won't boot in raid, so I can't dual boot. BUT I want to dual boot.

This is where the stupidity comes in:
I'm typing this as I wait for windows to back up all my fiels of the HD onto an external disk.
I'm going to install Ubuntu in RAID mode and then reinstall vista, also in raid mode. I have no idea if this will work. It's 50GB till it's backed up, I got half a pack of smokes, a full tank of gas, it's dark and I'm wearing sunglassess.

Lets hit it.
Other Links From Ubuntu:
koomber1664 Avatar
8y, 10m agoPosted 8 years, 10 months ago
Options

All Comments

(12) Jump to unreadPost a comment
Comments/page:
#1
did you try to install ubuntu using Wubi?
banned 1 Like #2
#3
Nor Wubi or booting from the CD works (for me) unless I change the SATA from IDE to RAID.
I'm writing this on my laptop at teh moment so I'll be able to keep everyone updated on progress, even when I've set fire to the Desktop and am dancing round it in a Shamanistic kind of way.

EDIT: Here's a link to the Ubuntu bug report on this issue
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/153702
banned#4
koomber1664;1969564


EDIT: Here's a link to the Ubuntu bug report on this issue
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/153702


Im just installing using Wubi on my Dell Vostro. Will let you know if the issue exists in this laptop. Sounds like it may do!
#5
My biggest concern at teh moment (besides my girlfriend kicking hte seven shades of sh..ugar out of me) is the whole RAID thing. I have no experience with it, so I don't know how it will behvae. ah well, we learn by doing...

UPDATE: Well thats me installing now.... here's hoping that it all goes well

UPDATE 2: The install is finished now. Just restarting...... orange bar is filling up (LOADING!) It works. Now to update the drivers....
EDIT: UH OH. The screen keeps flickering. that can't be good
banned#6
Ive just installed. Everything seems fine. Duel booted into both ubuntu and Windoze. SATA seems fine without RAID.

Now to work out wireless networking!
#7
Well I seem to have Ubuntu working fine now. Just need to figure what I'm missing and find stuff to install :)
banned#8
koomber1664;1969826
Well I seem to have Ubuntu working fine now. Just need to figure what I'm missing and find stuff to install :)


Well done.

Likewise!

Just need to work out wireless networking! Its a pain to have to reboot to get on the internet!
#9
4am

I love this time of the morning. I used to work night shifts in a 24 hour shop and this was the nice time when all the drunks had gone home and you had 3 hours to chill.

But I Digress.....

UPDATES:
I've got Ubuntu up and running and it's all looking good. It was actually a piece of cake getting it installed. If it wern't for whatever it was giving me grief, I would have been okay.
So, I've got Unbuntu installed, now I need to get Vista back on.

First things first, go here:
http://apcmag.com/how_to_dualboot_vista_with_linux_linux_is_already_installed.htm

That basically tells you everything you need to know.

The only difference, is that after you resize your drive, you need to right click on the unallocated space, then select format to and ntfs. After this you can skip the part about 'diskpart'. Vista should go on with no problems.

I say that, but I am watching it install right now. Thus far there have been no major problems and it is 'completeing the installation'

Updates when I get them.

EDIT: OH POOP. Forgot to include these links. I found these about 10 minutes into my Vista install (about 4 hourse too late)
http://www.dellcommunity.com/supportforums/board/message?board.id=vista&message.id=23453&query.id=18768#M23453

Also, windows isntalled fine. However, the ethernet and 'SM Bus controller' (eh?) didn't. Apparently it can't find the drivers..... /cry
banned#10
koomber1664
4am

I love this time of the morning. I used to work night shifts in a 24 hour shop and this was the nice time when all the drunks had gone home and you had 3 hours to chill.



Ha ha... youive been much more dedicated than me! I gave up the ghost with wireless at about 2am!

.

UPDATES:
I've got Ubuntu up and running and it's all looking good. It was actually a piece of cake getting it installed. If it wern't for whatever it was giving me grief, I would have been okay.
So, I've got Unbuntu installed, now I need to get Vista back on.

First things first, go here:
http://apcmag.com/how_to_dualboot_vista_with_linux_linux_is_already_installed.htm

That basically tells you everything you need to know.


Had a look. In comparrison to the method I used, its very much more convoluted. I already had XP installed and the Wubi installer had Ubuntu installed and duel booting within 30 minutes.


EDIT: OH POOP. Forgot to include these links. I found these about 10 minutes into my Vista install (about 4 hourse too late)
http://www.dellcommunity.com/supportforums/board/message?board.id=vista&message.id=23453&query.id=18768#M23453

Also, windows isntalled fine. However, the ethernet and 'SM Bus controller' (eh?) didn't. Apparently it can't find the drivers..... /cry


One thing is for sure. Running Ububtu is definately not as simple as running Windoze! I'm still trying to sus out so many things that would be obvious in the Windoze environment!

Are you networking hard wired or wireless? Dont suppose you found any reference to WiFi in your travels? Looking within the OS it quotes using an IP starting 127. Which kinda makes it clear why my wifi network is seen but wont connect. I have tried manually changing, but still no joy.
#11
@ guv, the 127. address is the loopback, just ignore that there will need to be an address assigned for the adapter which from the sound of it is not being detected
@koomber, Interesting bug u got there but as your version of windows detects the sata controller in raid mode which xp will not its an easy workround, keep meaning to have a look at ubuntu myself, if only i had the time lol
banned#12
maddogb
@ guv, the 127. address is the loopback, just ignore that there will need to be an address assigned for the adapter which from the sound of it is not being detected


Cheers for that.

Its all pretty weird. The wireless device definately was being detected and my network found. I entered the SSID and passwords etc and it tried to connect but failed to do so. (I used DHCP automatically assigned)

However, I now only get the option for hard wired - so it now looks like its lost the wifi device as youve suggested!

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Looking for Twitter login?
Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!