Is my Xbox 360 on its last legs? - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HotUKDeals, you accept our cookie and privacy policy.
Get the HotUKDeals app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

Is my Xbox 360 on its last legs?

£0.00 @ ITS
I've got no red lights (yet!) but my xbox 360 seems to be taking an absolute age to boot up. I can have it turned on for a minute before the dashboard comes up on screen but it always used to be prett…
Evil_monkey Avatar
7y, 6m agoPosted 7 years, 6 months ago
I've got no red lights (yet!) but my xbox 360 seems to be taking an absolute age to boot up. I can have it turned on for a minute before the dashboard comes up on screen but it always used to be pretty instant - you know, turn it on and there's the dashboard straight away.
Any ideas what the problem could be (apart from my obvious impatience obviously)?
Other Links From ITS:
Evil_monkey Avatar
7y, 6m agoPosted 7 years, 6 months ago
Options

All Comments

(12) Jump to unreadPost a comment
Comments/page:
#1
it's on its way out mate, but might be fine for a couple of months, you never know!
#2
djdelmar
it's on its way out mate, but might be fine for a couple of months, you never know!


That's what I thought someone might say. Blummin' Microsoft rubbish.
#3
ps3 ftw! :-D
#4
Inquisitor
ps3 ftw! :-D


Oh let's not get into that debate! :-D:p
banned#5
You could try to induce 3 RROD and get it fixed up by M$.
#6
http://tbn2.google.com/images?q=tbn:D3kGNJ8blGYDMM:http://www.cemeterybroker.com/Funeralgoods_images/Funeral_goods.bmp
#7
sometimes my 360 takes long to load up the dashboard but that's always because my internet connection is pretty crap at times so it takes long to connect to xbox live and load everything up.
#8
mus_ne;6101168
sometimes my 360 takes long to load up the dashboard but that's always because my internet connection is pretty crap at times so it takes long to connect to xbox live and load everything up.

+1
try taking the ethernet cable out, mine takes longer with it plugged in, i'm guessing it notices theres no network connection so skips attempting to sign into live.

At least if you try this and it speeds things up you know its nothing serious.
#9
i had a similar prob with mine....
i unplugged my hd-dvd drive and it the dash started loading up instantly! If you have a hd-dvd drive, give that a go and see if it helps!

Amb
#10
Its on its way out.
When it does get red lights just phone up MS and send it in for repair, mine only took a week from the day I sent it in, to the day I got it.
#11
Blocparty12
Its on its way out.
When it does get red lights just phone up MS and send it in for repair, mine only took a week from the day I sent it in, to the day I got it.


The last time I sent mine back (1 red light) they got it back to me really quickly. I think if I keep getting problems I'll just phone them and tell them it's got the RROD and see what happens.
#12
Evil_monkey
The last time I sent mine back (1 red light) they got it back to me really quickly. I think if I keep getting problems I'll just phone them and tell them it's got the RROD and see what happens.

thats what i did, don't think they even checked.:)

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Looking for Twitter login?
Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!