my speedfight 50 makes horrible noise when i first start it up at low speeds - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

my speedfight 50 makes horrible noise when i first start it up at low speeds

bellj02 Avatar
9y, 3m agoPosted 9 years, 3 months ago
my speedfight 50 makes horrible noise when i first start it up at low speeds the noise soon goes away but its very horribe this has only just started happenin.
and when i indicate right its blinks about 3 times quicker than on the left and it blew one of my bulbs i was wondering if any 1 nos how to sort out these problems thanks
bellj02 Avatar
9y, 3m agoPosted 9 years, 3 months ago
Options

All Comments

(4) Jump to unreadPost a comment
Comments/page:
banned#1
get a car or if thats not an option get a push bike! better for us all
#2
Put a new bulb in, that'll sort the indicator flashing.

As for the noise at the start. Starter motor could be on the way out. Take it to a garage.
#3
thornedlily
Put a new bulb in, that'll sort the indicator flashing.

As for the noise at the start. Starter motor could be on the way out. Take it to a garage.



thanks for my dad just told me about the indicator lol im just waiting for some new ones to arrive, that doesnt sound good then iv only had it like 3 weeks not from new but even still il fone the dealer rite now.
thanks
#4
he seems to think the rollers mite be goin which is a pain but i spose it cud be worse

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!