My w300i is broken, help! - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

My w300i is broken, help!

pitsapatsa Avatar
8y, 3m agoPosted 8 years, 3 months ago
I have had my phone since may '07 so it is still in waranty but everytime I open it I just get a white screen. I have lost the receipt and purchased this phone from tesco. Can anyone help me? :thinking:
pitsapatsa Avatar
8y, 3m agoPosted 8 years, 3 months ago
Options

All Comments

(4) Jump to unreadPost a comment
Comments/page:
#1
My daughters 580i went like that after she dropped it, it just needed a new screen which was about £11.00-12.00 delivered from an ebay seller. Very easy to fit.
#2
try connecting the phone to SEUS as it may be a software error....this will lose all txts, pics etc tho. Otherwise it can still be returned to SE as they have a 2 year warranty. Ring them on 08705 23 7237. they book it in over the phone and give you a freepost address to send it to them.
#3
Meangreenie
My daughters 580i went like that after she dropped it, it just needed a new screen which was about £11.00-12.00 delivered from an ebay seller. Very easy to fit.


Thanks, I can still make calls but I have to call and not see the numbers come up. It also plays music when i press the walkman button and makes noise when i call it, so it's not totally scwred. Many thanks!


shanecr
try connecting the phone to SEUS as it may be a software error....this will lose all txts, pics etc tho. Otherwise it can still be returned to SE as they have a 2 year warranty. Ring them on 08705 23 7237. they book it in over the phone and give you a freepost address to send it to them.


Thanks if this fails I will give them a ring and ask if they will accept it desite the fact I have no receipt. Thanks !
#4
Had this problem.

Firmware problem...

Look here to start with....

http://forums.cnet.com/5208-7813_102-0.html?forumID=74&threadID=276898&messageID=2660848

and then from here.....

http://www.google.co.uk/search?hl=en&q=w300i+screen+white&btnG=Google+Search&meta=

hope you get it fixed.....

renagade27

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!