Need Help - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HotUKDeals, you accept our cookie and privacy policy.
Get the HotUKDeals app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

Need Help

£0.00 @
Hi, don't know if anyone can help. I bought my dad a Kodak C142 camera for christmas. Everything has been working fine until he deleted all of the pictures. Now it won't accept any SD Cards. Says Card… Read More
loopylorna Avatar
6y, 3m agoPosted 6 years, 3 months ago
Hi, don't know if anyone can help. I bought my dad a Kodak C142 camera for christmas. Everything has been working fine until he deleted all of the pictures. Now it won't accept any SD Cards. Says Card is "Unusable"?? The card is working fine in my camera though. If anyone can shed some light I would be really grateful. Thanks in advance
loopylorna Avatar
6y, 3m agoPosted 6 years, 3 months ago
Options

All Comments

(5) Jump to unreadPost a comment
Comments/page:
1 Like #1
Try reformatting the card in the camera.
Also the camera might not accept high speed cards.
2 Likes #2
He's not forced it in backwards has he and damaged a pin?
1 Like #3
Yeah i would reckon a in camera format should do the trick.
Is there a factory reset somewhere maybe that would help
1 Like #4
I would agree with harlzter, sounds as if at some point the card was removed and re-inserted and in doing so some damage occurred to the connector inside the camera.
#5
Thanks very much

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!