Need help, gaming headset mic won't work? Creative Soundblaster X-Fi Xtreme/Fatal1ty headset. - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

Need help, gaming headset mic won't work? Creative Soundblaster X-Fi Xtreme/Fatal1ty headset.

aphex187 Avatar
7y, 11m agoPosted 7 years, 11 months ago
Hey there!

Ive got the x-fi soundblaster card installed and ive plugged the the Fatal1ty headset in the back (green in green and the pink for the mic in the blue), i get sound in the earphones but im getting nothing from the mic.

Downloaded the latest drivers and made sure that the mic is on in Windows.
Other Links From Creative:
aphex187 Avatar
7y, 11m agoPosted 7 years, 11 months ago
Options

All Comments

(5) Jump to unreadPost a comment
Comments/page:
#1
mic normally goes in pink socket so check that, also its normal to have no sound coming out from the mic as this would cause feedback if not careful. it goes in but only comes out "other end"
windows xp has a mic setup routine wizard in control panel would have thought vista would have something similar.
#2
Well Soundblaster cards are a bit silly because as i would of thought pink goes in pink, but with these cards it actually goes in the blue socket! Im actually testing the mic on Left 4 Dead as you can do a mic test and im getting zip!

Ive tried the Windows wizard and that came up with nothing as well!
#3
aphex187
Well Soundblaster cards are a bit silly because as i would of thought pink goes in pink, but with these cards it actually goes in the blue socket! Im actually testing the mic on Left 4 Dead as you can do a mic test and im getting zip!

Ive tried the Windows wizard and that came up with nothing as well!


oh dear, any other pcs around to test mic with?, has any creative software taken control of unit.
assuming its a passive mic so set mic boost to on if you come across that but make sure your levels are down when you do.
#4
kk bud gonna check on that mic boost because ive just been looking for the bloody thing and i can't seem to find it!
#5
I read a review on a website recently and the person stated that you plug the headset in without the mic attached when first using it in Windows.

Try uninstalling and try again without the mic. Then plug mic in after the speakers have been detected.

HTH

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!