Nokia 5800 and wireless conection problems - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Nokia 5800 and wireless conection problems

strobez1977 Avatar
7y, 7m agoPosted 7 years, 7 months ago
Hi i have been using my nokia 5800 to connect through my wireless router but for some reason the phone keeps losing conection with my router,just wondering if there is a setting on my router or phone that i need to change.

Other Links From Nokia:
strobez1977 Avatar
7y, 7m agoPosted 7 years, 7 months ago

All Comments

(13) Jump to unreadPost a comment
The 5800 has really good wifi so it may be your router.Does it have an aerial attached to it ?.What modelis the router?
yeh it has a areial,its a siemens gigaset SE587
Looks like there is a hardware problem on some 5800's with Wlan - dont know if your s is one of these though

i can get connected fine its just that it randomly disconects
Can you give more details,Does this happen when moving about or when a certain distance away from your router or after a set lenght of time,Can you reconnect without re entering your pass key ?
yeh i dont need to re enter the web key,this happens when im upstairs in my bedroom,the router is downstairs in the lounge
When upstairs on your phone go to
wireless lan
and it will tell you your signal strength,
Whilst your phone is in this setting you can try it in differentplaces in your house but you will need to wait for a few seconds for it to refresh,If you are getting a low reading you can try changing the position of your antenna and rechecking ,some times this can make quite a difference,
strenth is 95% upstairs
With mine i get 100% at the router and 80% upstairs in my bedroom,
Could be interference from other wifi sources or other electrical devices such as microwave ovens or cordless telephones ,Try to think if the loss of signal happens at the same time as some other electrical device is being used,
Try changing the channel that the router is using. Chances are you haven't changed it from the default and it's interfering with your neighbours router who probably hasn't changed it from the default channel either.
still no good,also now the signal strength is showing as weak when im upstairs
I have got the Nokia 5800 from one week ago.
I have the same problem.
In 5 minutes (random) I lost the wireless connection in all applications.
I try with more wifis, but same result.
I didn't update the firmware.
Any idea, please?

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!