Onkyo SR-607 just stopped working :( - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

Onkyo SR-607 just stopped working :(

think Avatar
6y, 5m agoPosted 6 years, 5 months ago
pulled the Onkyo out from my cabinet and the HDMI cable shot out as a short lead to TV.... then got a fuzzy turquoise coloured picture...tried other cables to no avail....only had it 4 months so off to be repaired under warranty....it looks like the HDMI card needs repairing which will take 1-2 weeks depending on parts in stock etc.....

What am I going to do without full 5.1 sound for movies and the world cup?
The vuvuzelas will sound awful through the TV rather than all around me like bees!
Tags:
think Avatar
6y, 5m agoPosted 6 years, 5 months ago
Options

All Comments

(3) Jump to unreadPost a comment
Comments/page:
1 Like #1
you shouldn't have brought cheap unknown brands mate...for a few quid more you could have got a sony:whistling:
#2
N_W2003
you shouldn't have brought cheap unknown brands mate...for a few quid more you could have got a sony:whistling:


laughs - you just wouldn't let it lie!! To quote Vic Reeves....
#3
had to be done:thumbsup:

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!