PC Hard drive help please!! - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

PC Hard drive help please!!

cycleman Avatar
9y, 6m agoPosted 9 years, 6 months ago
Anyone help me with this I'd be very grateful.
Just bought a maxtor internal 250gb h/drive, didn't think at the time that it was sata and my PC is IDE...got a IDE to Sata converter which alows me to format the hard drive but when it comes to installing the operating system it just 'blue screens' and comes up wit a load of error messages not seeming to recognise the drive.
I managed to find a couple of sata ports on my motherboard which shows the new drive in 'my computer' (I ended up reinstalling an old IDE drive just to get back on line).
Is there any way I can get the Sata drive as my main drive with XP on rather than just using it as a second drive for storage??:?
cycleman Avatar
9y, 6m agoPosted 9 years, 6 months ago
Options

All Comments

(4) Jump to unreadPost a comment
Comments/page:
#1
Just to clarify you have the drive installed ok in a SATA port now right?

If so then:
When installing WindowsXP you may need drivers for your SATA controller on a floppy disk (get these from your motherboard manufacturers website), you'll have to press F6 (I think) when it asks if you need to install a third party SCSI or RAID driver and then follow the prompts.

To boot from the SATA drive you will have to change your bios settings to boot from the SATA drive before your old IDE drive (usually get into the bios settings by hitting 'del' on boot).

Hope that helps
#2
Thanks for that, problem is the drive on my sata is not showing up in the bios even though it shows on 'my computer'
#3
[Providing your using XP or Vista] Start > Control panel > Administrative tools > Computer Management > Disk Management > [Right Click the drive that you've just installed] > Format > Mark Partition as Active.

This should set it as a live hard drive and should be readable from bios, thats the last thing i can remember.
#4
cycleman
Thanks for that, problem is the drive on my sata is not showing up in the bios even though it shows on 'my computer'


Depending on your motherboard the drive may not actually show up in the bios settings at all, sometimes just the SATA controller will (after installing Windows you boot to that and it will be that which selects the drive). But it should flash up connected devices during POST (although this may be too quick to notice on some machines, so don't worry too much). If Windows can see it then the Windows installer should see it (after hitting F6 and adding the drivers of course) and if you can install Windows you should be able to boot to Windows.

Hope that helps

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!