Problem Joining friends games on call of duty - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HotUKDeals, you accept our cookie and privacy policy.
Get the HotUKDeals app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

Problem Joining friends games on call of duty

£0.00 @
Hi when I get a invite to join a private game on call of duty mw 2 it shows me on the list if players then suddenly it says game lobby closed, I also noticed it's not showing the icon for my mic yet i… Read More
strobez1977 Avatar
7y, 6m agoPosted 7 years, 6 months ago
Hi when I get a invite to join a private game on call of duty mw 2 it shows me on the list if players then suddenly it says game lobby closed, I also noticed it's not showing the icon for my mic yet it's plugged in etc, I also have the same problem when I join a friends game in progress


Ps this is the 360 version
strobez1977 Avatar
7y, 6m agoPosted 7 years, 6 months ago
Options

All Comments

(14) Jump to unreadPost a comment
Comments/page:
#1
Is your Nat status open, strict etc when you go into the multiplayer screen it should say what your nat status is....
#2
gari189
Is your Nat status open, strict etc when you go into the multiplayer screen it should say what your nat status is....


Hi it says moderate
#3
strobez1977
Hi it says moderate

do I need to change if if so how do I do this??
[mod]#4
you really need to change your router settings so it says NAT open

what router u got? make + model?
#5
goonertillidie
you really need to change your router settings so it says NAT open

what router u got? make + model?


hi its siemens gigaset 587 wlan dsl
#7
cant realy see what i ned to change, that links for a diff problem m8
#8
The moderate status is very likely to be your problem - your nat should be open. Best thing to do is google the name of your modem with the additional words "xbox live nat" and see what comes up.....
#9
gari189
The moderate status is very likely to be your problem - your nat should be open. Best thing to do is google the name of your modem with the additional words "xbox live nat" and see what comes up.....


checked that but cant find much info on what to do, seems others have had the same problem
#10
strobez1977
checked that but cant find much info on what to do, seems others have had the same problem


I had to setup port forwarding on mine but I'm not an expert and it took a while to sort out. Try looking on [url]www.portforward.com[/url]
#11
gari189
I had to setup port forwarding on mine but I'm not an expert and it took a while to sort out. Try looking on [url]www.portforward.com[/url]


^ Do this. Going to sort mine out tomorrow.
#12
DragonChris
^ Do this. Going to sort mine out tomorrow.


did it work for ya?
#13
gari189
I had to setup port forwarding on mine but I'm not an expert and it took a while to sort out. Try looking on [url]www.portforward.com[/url]


did port forward make it work for u?
#14
strobez1977
did port forward make it work for u?


Yes it did but I would only go down this route if there are no simpler ways. My modem is an older one and plugnplay didn't work.....

Instructions for your modem are on the link below but don't do this until you've read a bit more about port forwarding.
http://www.portforward.com/english/routers/port_forwarding/Siemens/GigasetSE587/Xbox_Live_360.htm

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!