Problem with O2 broadband tonight - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

Problem with O2 broadband tonight

drmsa Avatar
8y, 1m agoPosted 8 years, 1 month ago
Hey guys is it just me who is having problems with 02 broadband tonight, or is it a general thing?

Some websites are taking ages to upload. Although I am getting a good speed of 9MB+/sec online with speed test websites.
Other Links From O2:
drmsa Avatar
8y, 1m agoPosted 8 years, 1 month ago
Options

All Comments

(8) Jump to unreadPost a comment
Comments/page:
#1
mine seems to be ok
#2
just cant find out a reason. just spoke to O2 customer services, who seem to be surprised and did not have any answers.

i still cant get to fleebay and few other websites. nothing really specific though, however hotukdeals, bbc and google seem to be working perfect!
#3
Im with Be Broadband, bought by O2, and im getting the same problem. Ebay, Newgrounds don't work..., but hotukdeals, hotmail, google, bbc, other email all work. It seems that some specific websites are affected.
#4
Artonox
Im with Be Broadband, bought by O2, and im getting the same problem. Ebay, Newgrounds don't work..., but hotukdeals, hotmail, google, bbc, other email all work. It seems that some specific websites are affected.


Thanks a lot for that posting.....atleast its not just me who is affected! Hopefully they should be able to fix the problem.

Thanks once again!
#5
Im having the same problem cant get on eBay or facebook tonight
#6
Same problem for me for some sites.

Websites were working fine the last few days, but the speed was slow. I first notice it on Thursday and have been checking the broadband speed until sunday. It was very slow compared to normal speed of 15mb. They fixed it today, the speed is back up to normal but now some of the sites don't work.
#7
have any of you raised the issue up with O2/Be at all??

As i mentioned earlier, I did raise the issue up and ask them about it, but they were completely unaware of any such issues. And have asked me to ring them again tomorrow, if the problem persists. I will keep you all posted if I get any new updates from them!
#8
same problem here (O2) i need to change the host to get acess to some sites, very annoying

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!