Problems With Navman 530 - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit
Expired

Problems With Navman 530

saxo_appeal Avatar
1d, 5m agoPosted 1 decade, 5 months ago
Ok im having big problems with Navman 530, it just wont register, it keeps coming up an "send an error report" when i click on register maps ARRGHHH !!!

its really doing my head in, has anyone had this same problem?
iv tried un-installing the files and re doing them again but its still doing it.

does anyone think it might be the cd or my comp might have a hidden virus?
iv done a full scan but nufin lol

cheers, (dont think ill get much replys on this one but im trying anything at the moment :(
saxo_appeal Avatar
1d, 5m agoPosted 1 decade, 5 months ago
Options

All Comments

(2) Jump to unreadPost a comment
Comments/page:
#1
Hi I had a similar problem with my father inlaws navman and to be honest the easiest thing to do is either look for service packs on their website and try again or call the support line, they are very helpful and quick at sorting the problems. I say install any service packs as they will ask you to do this first. hope this info helps

:thumbsup::thumbsup::thumbsup::thumbsup::thumbsup:
#2
If anyone has read this thread then my Navman thread for sale,

This navman i took back to argos and was given another one which works perfectly.

hope this thread didnt put anyone off.

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!