PS3 Blu-ray picture very red... any ideas? - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

PS3 Blu-ray picture very red... any ideas?

Degeneratemoo Avatar
8y, 1m agoPosted 8 years, 1 month ago
I'm using a ps3 on a standard widescreen (SD) telly through the 3-port scart lead but I have a problem with blu-ray playback.

Games play great (though obviously not in HD and in case anyone asks why I'm watching blu-ray films on a SD set it's because I don't want to buy the films I want to watch twice) and DVD's are fine but yesterday I purchased my first blu-ray film (Beowulf) and the picture colour is awful, it's really bright red!

Now this is a problem that I used to have with my old DVD player when playing region 1 DVD's (I'm region 2) and I managed to fix it by changing the NTSC & PAL settings but there doesn't seem to be that option.

Like I say, games play great, as do region 2 DVD's (can't check region 1).

My TV has 4 settings for the picture colour, Automatic, PAL, 4.43 NTSC and 3.58 NTSC. When in the PS3 main menu, Auto & PAL will display in colour, both of the NTSC settings are black and white. When playing Beowulf, PAL & 4.43 NTSC are B&W whilst Auto & 3.58 NTSC are in colour (albeit very bright red).

Here's some links piccys that should show the problem:

This is what my region 2 Babylon 5 DVD looks like:

http://www.slightlyclothing.co.uk/pics/06102008296.jpg

and this (note although it looks a little red on the faces the picture is fine on screen):

http://www.slightlyclothing.co.uk/pics/06102008297.jpg

This is the Beowulf blu-ray:

http://www.slightlyclothing.co.uk/pics/06102008298.jpg

and a shot from the film:

http://www.slightlyclothing.co.uk/pics/06102008299.jpg

As stated, when set to PAL & 4.43 NTSC colour the blu-ray playback is B&W:

http://www.slightlyclothing.co.uk/pics/06102008300.jpg

And when set it 3.58 it's in the glowing red colour:

http://www.slightlyclothing.co.uk/pics/06102008301.jpg

and one final shot for good measure (which really shows how red it is):

http://www.slightlyclothing.co.uk/pics/06102008295.jpg

Oh, in case anyone spotted it, the cables plugged into the front of my TV is the Wii. Also, the 3 plug scart adaptor that came with the PS3 wouldn't fit my TV so I used the one from the xbox, would this cause any problems?

I appreciate this is a bit of a long post but I appreciate any help that people can give!

Many thanks,

DG
Degeneratemoo Avatar
8y, 1m agoPosted 8 years, 1 month ago
Options

All Comments

(1) Jump to unreadPost a comment
Comments/page:
#1
Loose cable most likely. Check both ends.

Also check the colour settings on the TV.

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!