TomTom 720 fault...any help greatly appreciated! - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

TomTom 720 fault...any help greatly appreciated!

Foxy102 Avatar
7y, 1m agoPosted 7 years, 1 month ago
Hi all

I have a fault with my TomTom 720. I have tried everything that other forum have, but still cannot get it to work OK, so my only ray of hope is if any of you guys have had the fault also.

The other day I turned it on and the TomTom logo appears (it doesn't usually), then it took a while and showed me a screen of the TomTom, a picture of a harddrive (i think) and a red circle with a white cross in it. I turned it off and did the reset. Same thing. I then let it to charge for ages and did it again. Same thing. I then tried to connect it to my PC to TomTom home and it says device not connected. Now the weird thing is that when I did this and turned the Tom Tom on, the harddrive symbol and cross goes away, and is replaced by a pic of the TomTom on its own with no warning symbol. It still says device not connected and the TomTom won't do a thing.

Explorer says that there are devices in the F and G drive but when I click on them it says "Please insert a disk into drive F:

I have it backed up, but can't get it to be recognised on explorer!

Can anyone help?


Other Links From TomTom:
Foxy102 Avatar
7y, 1m agoPosted 7 years, 1 month ago

All Comments

(10) Jump to unreadPost a comment
Its chuffed it m8...bin it and get a new one. :thumbsup:
you can contact tom tom for advise,they repaired my go 300 free of charge ! worth a try
have you tried reformatting the drives in explorer? if you have a backup could you format and copy it back?
I have tried to format the F and G drive (to re-install) but it won't let me as it says there is no disk in drive F/G
it sounds as though the flash memory has broken. you may have some success with partitioning tools or low level format tools but it sounds borked to me mate sorry
Thanks guys...

...gutted. My telly just broke as well. What a poo day im having :cry:
Found this on avforums today, I got the same problem, so will try it out

In this email you will find the solution for the error on your TomTom. This solution can be used in the following situations:

• The device hangs in the start screen (splash screen)
• An SD-card with a red cross is displayed on the screen
• A picture with a red dot and white cross is displayed
• The device can’t be turned off

If you haven't already done so, please download and Install TomTom Home from

If you don’t have a full backup of your TomTom yet we advise you to make one before continuing with the steps in this email. You can make a backup by following the steps below:

1. Reset your TomTom device: and connect it to your computer.
2. Click on 'Backup and Restore -> Backup' in TomTom Home 2.0
3. Enter a name for the backup and click [OK]
• IMPORTANT: When the software is asking to delete parts from the backup click [NO]

After the backup is made you delete the files from the root directory of the TomTom. Follow the steps below to do this:

1. Reset your TomTom device: and connect it to your computer.
2. Open My Computer in Windows, or Finder in Macintosh from your desktop and turn on your TomTom device.
3. On your screen a new removable disk appears, this is your TomTom device, click on the disk to open it.
4. You will see a list of folders and a list of loose files
5. Delete all of the loose files. IMPORTANT: The folders with their content must NOT be deleted.
5. Close the window when all files are deleted by clicking on the [x].

Next we will reinstall the application via TomTom HOME.

1. Start TomTom HOME on your computer
• TomTom Home should automatically check for updates and prompt you to install them, if not:-
2. Click on 'Update my device'. If you get the message 'No Items Available', or there is not an application to download, click on 'Add Maps, Traffic, Voices etc -> Items on my computer', select the application and click on 'Add'.
3. Select the Application update.
4. Click on 'Device -> Disconnect Device', then turn off your device when it is done installing and disconnect it from your computer.
5. On a PC, in the System Tray by the computer clock, click on the 'Safely Remove Hardware' icon and disconnect the TomTom also in this way.

When switching on the device it should boot as normal again.
when l switch it on, it comes out with tomtom logo , later start asking question from language up to voice and end up with a green light and sign x later go off and start again
Wow this has come back after a long while! I got in touch with TomTom direct and they ended up replacing if free of charge as it had a 'corrupt memory'. It turned out that this wasn't actually the fault, the charger was at fault (a factory fault apparently)

Edited By: Foxy102 on Jan 20, 2011 13:24

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!