TV/Car help...? - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

TV/Car help...?

pawsntails Avatar
9y, 2m agoPosted 9 years, 2 months ago
Hi Guys,

I have an '03 MG ZT+ that has a built in tv/sat nav in the dash board which also acts as my multi CD changer. Now not being technically minded I'm kinda confused. The TV has all the norm channels and then it has an AV channel. Now I maybe wrong but aren't AV channels the ones set aside to show dvds/videos/comp games etc? If so than you'd assume there would be some kind of socket somewhere for me to plug something in, but i can't find it and its driving me nuts.

I've tried putting a DVD in the CD changer incase thats how it works but nothing happened. I've also looked everywhere I can think of for a place to plug something in. Does anyone have any ideas, or am I wrong about av channels in general, in which case what is it for?

I tried asking the previous owner of the car, but he said he'd never really used the TV so didn't know. Its annoying as I can't even go to a dealer as Rover aren't around anymore.

Any help would very much be apprieciated!
Tags:
pawsntails Avatar
9y, 2m agoPosted 9 years, 2 months ago
Options

All Comments

(4) Jump to unreadPost a comment
Comments/page:
#1
A DVD won't work in a CD changer (it will only read CDs)

The socket is probably at the back of the unit (i.e. buried in the dashboard) and is as you say to plug a DVD etc in.
#2
So, prob no chance of getting to it unless I take it into a mecanics? If so grr, I really can not afford that just to play a dvd lol
#3
depends on whether or not you can get the 'head' unit out of the dash - i'm guessing the stereo's head unit would have the connections on the back of it. Beware, sometimes removing the stereo will invoke the passcode, which you'll need to enter when you switch it back on

edit - perhaps the connections are on the multichanger?
#4
Have you contacted an MG garage or looked in the user manual for the car?

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!