Vista Removable Media Help - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

Vista Removable Media Help

katymaty Avatar
7y, 11m agoPosted 7 years, 11 months ago
I have Windows Vista and was just transferring some files to an MP3 player.

Normally when I transfer files to an MP3 or memory stick once completed I just right click on the removable media In My Computer then select Safely Remove.

But that option didn't appear this time so I clicked on Eject instead, which I assumed would do the same thing.

Now my removable disk doesnt appear in my Computer. I rebooted and then plugged MP3 player back into USB slot but nothing happened.

Any ideas???????
katymaty Avatar
7y, 11m agoPosted 7 years, 11 months ago
Options

All Comments

(12) Jump to unreadPost a comment
Comments/page:
#1
I never safely remove hardware. Have u tried a diff usb slot?
#2
I never safely remove. As long as your not transferring files when you unplug the device you shouldn't have any problems.

Have you got another computer to try it on?
#3
Tried both USB slots. Nothing happened.

Normally when I connect a USB device u get the pop up box asking to open files etc but not now:x
#4
It sometimes does this if the disc / drive is corrupted. As advised, try it on another computer first.
#5
I have had a lot of probs with mp3 players (cheap ones). They just stop working! I now have a sony one and its great
#6
Predikuesi
It sometimes does this if the disc / drive is corrupted. As advised, try it on another computer first.


I have just plugged a memory stick into my PC and it recognised it and shows as removable DIsk (J:), but if I click on safely remove or just pull the memory stick out the J Drive just disappears from the My computer View.

The MP3 doesnt get recognised :?

So when instructions says always safely remove, none of you guys ever do it LOL. and does it make a difference as long as you are transferring any data

ALso what is the EJect option supposed to do
#7
bargainhunter2009;4330727
I have had a lot of probs with mp3 players (cheap ones). They just stop working! I now have a sony one and its great


Same here. I had a brilliant (and expensive) one, until my wife left it in the glovebox one day in Summer and fried it:cry:
#8
katymaty;4330784
I have just plugged a memory stick into my PC and it recognised it and shows as removable DIsk (J:), but if I click on safely remove or just pull the memory stick out the J Drive just disappears from the My computer View.

The MP3 doesnt get recognised :?

So when instructions says always safely remove, none of you guys ever do it LOL. and does it make a difference as long as you are transferring any data

ALso what is the EJect option supposed to do


Yep. I never use the "safety" or "eject" either. I have a feeling, but I hope I'm wrong, that the MP3 player is dead.
#9
Predikuesi
Yep. I never use the "safety" or "eject" either. I have a feeling, but I hope I'm wrong, that the MP3 player is dead.



EEK it only arrived today. Seems to work ok when I play the MP3's I just transferred.

Guess I wont Eject or safely remove in future :thumbsup:
#10
dont think eject matterred

Think its just not a very good mp3, I had a sansa one a while ago and it just stopped working an hour after i got it. Also had some of the cheap ones from argos and they are rubbish. Where did u get it from?
#11
katymaty;4330857
EEK it only arrived today. Seems to work ok when I play the MP3's I just transferred.

Guess I wont Eject or safely remove in future :thumbsup:


Oh that's great. It must be in good order then. It must be a driver problem on your computer. See if it goes back to normal after you restart it. A System Restore might help too, or whatever it is called in Vista. Hopefully the computer will see the MP3.
#12
:thumbsup:
Rebooted again and did system restore

seems to be ok now although have to wiggle it alittle bit to recognise the device

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!