Xbox 360 Firmware Help - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

Xbox 360 Firmware Help

michaelanderson Avatar
6y, 9m agoPosted 6 years, 9 months ago
What Firmware do i need for a 360 console to play all waves without putting in active.iso disc before hand?
michaelanderson Avatar
6y, 9m agoPosted 6 years, 9 months ago
Options

All Comments

(10) Jump to unreadPost a comment
Comments/page:
1 Like #1
1.61 or LT if you have a LiteOn drive
#2
oldmanhouse
1.61 or LT if you have a LiteOn drive


Thought 1.61 wont play wave 5?
Also could i revert back to older firmware as wont be playing online?
#3
1.51 on my console, plays everything fine.
#4
Not sure about Wave 5s with 1.61 - I skipped over it and went straight from 1.6 to LT..

As for reverting to an older firmware, I don't see why not. You can flash with 1.5 or something older if you want - I think people did that for a while, flashing back to 1.4 as I think it will boot any games, regardless of wave? Could be wrong about that so will wait for some confirmation from someone more knowledgeable..
#5
oldmanhouse
Not sure about Wave 5s with 1.61 - I skipped over it and went straight from 1.6 to LT..

As for reverting to an older firmware, I don't see why not. You can flash with 1.5 or something older if you want - I think people did that for a while, flashing back to 1.4 as I think it will boot any games, regardless of wave? Could be wrong about that so will wait for some confirmation from someone more knowledgeable..


Thanks for that and rep left:thumbsup:
#6
if your not planning to play online give me a pm will give you a link to non-stealth fw
#7
Babbabooey
1.51 on my console, plays everything fine.


Does it play wave 5?
#8
djnaff
if your not planning to play online give me a pm will give you a link to non-stealth fw


Thanks, Not looking to flash myself looking to buy one already flashed.
Thats why i want to see what firmware i need:thumbsup:
1 Like #9
1.51 will only play all waves if you have a Hitachi drive.if you ahve a liteon pretty much all consoles released in last year prob even year and a half wil be liteon then get LT that will play all waves and future waves.

If you have another drive your best bet is to get a non stealth firmware e.g less than 1.4..

Also if you plan on going on live with said console then your supposedly only safe with LT at present(Liteons only at mo) make sure your backups (the actual disk) have split vid enabled, ssv2 enabled and pass all other abgx checks.
#10
Thanks for all help:thumbsup:

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!