xbox 360 rrod question - HotUKDeals
We use cookie files to improve site functionality and personalisation. By continuing to use HUKD, you accept our cookie and privacy policy.
Get the HUKD app free at Google Play

Search Error

An error occurred when searching, please try again!

Login / Sign UpSubmit

xbox 360 rrod question

sme24185 Avatar
6y, 9m agoPosted 6 years, 9 months ago
hi people tried to fix my xbox today, cleaned the cpu and gpu, shines now
put thermal paste on all 3 thin layer
then put the heatsinks on, screwed them up not to much.
waited about 1hr took to bros to use is power supply and

flash 4 red lights few sec
then 3 why?

what have i done wrong?

any advice? thanks
Tags:
sme24185 Avatar
6y, 9m agoPosted 6 years, 9 months ago
Options

All Comments

(15) Jump to unreadPost a comment
Comments/page:
banned#1
trying to fix it in the first place. Just buy a new one
#2
you do the hybrid fix? works great
#3
hybrid? whats that?
the thermal paste fix no good then?
#4
You replaced the X clamp with new bolts and washers?
#5
Do you have the AV cable plugged in?

If not plug it in, have the top of the case off and rest the fan over the DVD drive and the visible heatsink so that it's cooling that heat sink. Turn it on for half hour, if you get three red lights that's good, just leave it alone.

After 30 minutes turn it off, leave it for 15 minutes to cool and then put the fans and fan shroud back and test it again.
#6
no x clamp
watch youtube vid and did it like that
4 lights then 3
pluged just power cable in but didnt do it as soon as i put paste on, about 1hr later does that matter?
#7
hi people tried to fix my xbox today, cleaned the cpu and gpu, shines now
put thermal paste on all 3 thin layer
then put the heatsinks on, screwed them up not to much.
waited about 1hr took to bros to use is power supply and

flash 4 red lights few sec
then 3 why?

what have i done wrong?

any advice? thanks

You bought an Xbox...Glad I could help.
#8
sme24185;8232576
no x clamp
watch youtube vid and did it like that
4 lights then 3
pluged just power cable in but didnt do it as soon as i put paste on, about 1hr later does that matter?


No it doesn't matter how long you leave it after applying the paste, follow these steps and it's more than likely to fix it.

Plug in AV and Mains cable
Remove fan shroud and rest fan half over DVD drive and half over the visible heatsink
Tur console on, it may work but you'll likely get 3 red lights. Leave for 30 minutes.
Turn off, leave for 15 minutes to cool
Put everything back together normally and test

Make sure the AV Cable is plugged in :thumbsup:
#9
lol....
#10
ok ill try it again so keep it on for 30min with 3red lights flashing then turn it off
#11
sme24185;8232632
ok ill try it again so keep it on for 30min with 3red lights flashing then turn it off


Yes mate, it may get a bit noisy but that's OK, even if it works fine just leave it for 30 minutes anyway :thumbsup:
#12
Good luck! I'm just downloading Splinter Cell Conviction demo. I'll tell ya what it's like!
#13
anyone else tried the hybrid fix working a treat for me
#14
jamstaruk1972;8232725
anyone else tried the hybrid fix working a treat for me


I've not, it doesn't look like it is worth the extra effort. I find the normal fix very reliable.

If my jtag'd console got it I may look into it more but probably not.
#15
RedIron
I've not, it doesn't look like it is worth the extra effort. I find the normal fix very reliable.

If my jtag'd console got it I may look into it more but probably not.


not that much more hassle

Post a Comment

You don't need an account to leave a comment. Just enter your email address. We'll keep it private.

...OR log in with your social account

...OR comment using your social account

Thanks for your comment! Keep it up!
We just need to have a quick look and it will be live soon.
The community is happy to hear your opinion! Keep contributing!