286°
EXPIRED
Bookworm - only 59p iphone/ipod touch @ itunes
Bookworm - only 59p iphone/ipod touch @ itunes

Bookworm - only 59p iphone/ipod touch @ itunes

Buy forBuy forBuy for£0.59
GETGet dealVisit site and get deal
80% off until August 5th to celebrate the release of Bookworm 2.

Bookworm, players build words from contiguous letter tiles on a grid.
Longer and more difficult words score more points and produce a variety of
"gem tiles" that offer additional bonuses when used (and mega-bonuses when
multiple gem tiles are used in a single word). Burning tiles sear through
normal tiles, reaching the bottom of the grid quickly; they must be used
before they reach the bottom, or the game ends.

Exclusive features in the iPhone and iPod touch version include:
-- Shake to scramble letters: Simply shake your iPhone or iPod touch to
re-scramble the letters.
-- All new bonus bookshelf: Discover books filled with bonus words and
try
to complete the collection.
-- Track your progress: Just turn your phone sideways for a quick,
detailed
view of your word history and bonus bookshelf status.
-- A word collectors dream: Build your stats and show off all the best
words you've spelled!

10 Comments

mod

Thanks for posting El_Murph

You need to post a direct link for this.

I have searched the website and am unable to find this product

Emmajk42 wrote a couple of very comprehensive and excellent guide for newcomers to HUKD here: - hotukdeals.com/ite…ne/
hotukdeals.com/ite…779
They are well worth taking a look at.

Regards
andywedge

Original Poster

Link now added

mod

El_Murph;5896100

Link now added



Thanks :thumbsup:

I'll buying this when i get home, love PopCap games. Thanks for the heads up. :thumbsup:

Great game. Now all I need is an iPod Touch!

Nice catch, I love Bookworm and now I can play it on the go! Heat and rep added.

Thanks. Heated & repped :thumbsup:

Wait a minute. Does it work on 3.0? Says requires OS 2.2 or later, but there's usually a badge saying it works with 3.0, isn't there?

drspa44;5900019

Wait a minute. Does it work on 3.0? Says requires OS 2.2 or later, but … Wait a minute. Does it work on 3.0? Says requires OS 2.2 or later, but there's usually a badge saying it works with 3.0, isn't there?



Yes it works - hubby has just downloaded it onto his iPhone 3g :thumbsup:

Nice one

Heat & Rep Added

Make it so!

Soth 8-)
Post a comment
Avatar
@
    Text