-104°
EXPIRED
Ebuyer - Crucial M500 480GB £148.98 @ Ebuyer
Ebuyer - Crucial M500 480GB £148.98 @ Ebuyer

Ebuyer - Crucial M500 480GB £148.98 @ Ebuyer

Buy forBuy forBuy for£148.98
GETGet dealVisit site and get deal
Really good SSD, lowest price I've seen it, only a day long deal though.

I've had this drive for a year and it's a really good drive, it was about £180 when I got it so not a massive drop in price, but a decent deal.

12 Comments

Extra £7 get the 512GB version

ebay.co.uk/itm…856?ssPageName=STRK:MESELX:IT&_trksid=p3984.m1555.l2649

Original Poster

DuWolfy

Extra £7 get the 512GB … Extra £7 get the 512GB versionhttp://www.ebay.co.uk/itm/301414232856?ssPageName=STRK:MESELX:IT&_trksid=p3984.m1555.l2649



Fair enough, I didn't realise the mx100 was actually faster. Would help if they had a consistent naming system.

No worries, posting either helps someone buy or teaches you something for next time.

All good

;o)

DuWolfy

No worries, posting either helps someone buy or teaches you something for … No worries, posting either helps someone buy or teaches you something for next time.All good ;o)


Completely agree. Since I joined HUKD, I've learnt all sorts of things!

is m100 not a slave drive? i.e. no os can be installed?

cctwister1

is m100 not a slave drive? i.e. no os can be installed?



I hope not

cctwister1

is m100 not a slave drive? i.e. no os can be installed?

cctwister1

is m100 not a slave drive? i.e. no os can be installed?



Its not.

Are you getting confused with those old PCIe drives?
I believe you couldn't boot as os from them. Correct me if I'm wrong.

I have the 512GB SSD as a boot drive .. no probs @ all
Edited by: "DuWolfy" 2nd Dec 2014

my dad has a mx100 and it was a PITA to get windows on it, i work in IT but even i couldn't figure it out for ages, it wouldn't work in UEFI and Non-UEFI, eventually i managed to solve it but tbh i'm still not sure how. (updating the mobo bios was 1 of the things)

Scotta965

my dad has a mx100 and it was a PITA to get windows on it, i work in IT … my dad has a mx100 and it was a PITA to get windows on it, i work in IT but even i couldn't figure it out for ages, it wouldn't work in UEFI and Non-UEFI, eventually i managed to solve it but tbh i'm still not sure how. (updating the mobo bios was 1 of the things)



You must have had an olde motherboard having to flash it. I work in IT and most modern systems you just plug in and choose it as your boot device...

DuWolfy

You must have had an olde motherboard having to flash it. I work in IT … You must have had an olde motherboard having to flash it. I work in IT and most modern systems you just plug in and choose it as your boot device...



its a m5a78l-usb3 by asus so not very old, but yeah google "mx100 windows installation issues" i'm not the only one.

Yeah I have seen that board before , its a budget board from late 2010 early 2011. Usually older boarda need a bios update to support technology that comes out after its released which most of these SSD 's are
Post a comment
Avatar
@
    Text