155°
EXPIRED
EXPIRED - Freeloader Wii £2.99 Delivered @ 365 Games
EXPIRED - Freeloader Wii £2.99 Delivered @ 365 Games

EXPIRED - Freeloader Wii £2.99 Delivered @ 365 Games

Buy forBuy forBuy for£2.99
GETGet dealVisit site and get deal
IMPORTANT! - Compatibility with Wii Firmware 3.3x and higher

Unfortunately, due to circumstances beyond there control Wii Freeloader is not compatible with Wii firmware 3.3 and higher (released as an online update 17/06/2008).

You can continue to use Wii Freeloader perfectly with any Wii console running firmware 3.2 and below.

Wii Free Loader is really easy to use. Simply insert your FreeLoader disc and load it in the usual way. When the drive stops, eject the Wii FreeLoader disc and insert the game, which then loads and plays just like it would on its own region of Wii. Its as simple as that!

Wii FreeLoader is 100% unofficial, and requires no modifications to your console. As well as letting you play Wii games from all regions, Wii FreeLoader also works with imported GameCube games when played on your Wii. It wont work in a GameCube console, though for that, you need Freeloader for GameCube

* Play ANY region of Wii or GameCube game on ANY Wii.
* Easy to use
* No console modification required.
* Play games never released in your region.
* Play local games on your imported console.
* 100% unofficial.

15 Comments

good find good price

This also plays backups?

BFM

on disc or memory card ?

Original Poster

out of stock now

does this play backups ?

No, this won't play backups, unless something drastic has changed over the last few months that I've missed. I still think you need something like Wii Key etc.

thesilverfox;3350542

No, this won't play backups, unless something drastic has changed over … No, this won't play backups, unless something drastic has changed over the last few months that I've missed. I still think you need something like Wii Key etc.



Actually I think all you need now is Twilight Princess

The Twilight Princess hack only allows you to play Home Brew (ROMS etc) It won't allow you to play back up disks!

Iron-Man;3352523

The Twilight Princess hack only allows you to play Home Brew (ROMS etc) … The Twilight Princess hack only allows you to play Home Brew (ROMS etc) It won't allow you to play back up disks!



What he said. To play backups, you physically need to mod chip the Wii.

Iron-Man;3352523

The Twilight Princess hack only allows you to play Home Brew (ROMS etc) … The Twilight Princess hack only allows you to play Home Brew (ROMS etc) It won't allow you to play back up disks!



thesilverfox;3352962

What he said. To play backups, you physically need to mod chip the Wii.



No you don't. There are back up loaders that can be run through the homebrew channel . Compatibility is far from perfect at the moment, though.

the homebrew loaders are slow as hell, take upto 5 mins to load game and sound is always choppy!!

snotra;3353017

No you don't. There are back up loaders that can be run through the … No you don't. There are back up loaders that can be run through the homebrew channel . Compatibility is far from perfect at the moment, though.




Well, personally, I would consider the ability to play a key factor here. Playing and struggling along with limited sound and compatibility are two very different things! :w00t:

in stock now

thesilverfox;3357964

Well, personally, I would consider the ability to play a key factor here. … Well, personally, I would consider the ability to play a key factor here. Playing and struggling along with limited sound and compatibility are two very different things! :w00t:



Have you tried the latest loaders? The sound and speed issues have been ironed out.

Sure, if you're looking for near 100% compatibility now you need a modchip but your point was that it wasn't possible without. You can currently play the vast majority of backups absolutely perfectly without any hardware modification and compatibility will only increase.

With regard to the freeloader, you can achieve region free gaming through the homebrew channel using gecko os and that will work with firmware version 3.3.
Post a comment
Avatar
@
    Text