A really weird one, hope someone can help

Found 5th Jan
My wife and I own Xiaomi redmi 3s 3GB 32GB versions.
Worked perfectly for a time. Now something weird is happening.
At home both our phones have the same issue.
When making a call you never hear the phone ringing to know it's ringing at the recipient.
If they answer, the only way you know is the timer starts.
We can not hear anyone, but they can hear us.
Signal strength is good. Phones worked perfectly before.
This does not happen at work. Phone rings and I can hear people fine.
Is it the handsets?
Is it BT Mobile?

Any help appreciated, I know there's a few on here quite clued up on mobiles.
Thanks

  1. Ask
Groups
  1. Ask
17 Comments

call me, I'll explain

factory reset. Might fix it.

factory reset may fix it

does the phone automatically connected to any Bluetooth device when at home? Or maybe wi-fi calling? Try turning off Bluetooth and Wi-fi then make a call

It could be an issue with the mast in your area. Have you tried turning phone to 3G only and then 2g only. If it works on 3G but not 2g/4g (depending on where you live) it is probably going to be a mast issue.

Original Poster

Tried factory reset
Tried Bluetooth options
Phones says it's got 4G signal.
Text and data work fine.

Known issue with Xiaomi; my 3 mates have same issue. No-one can fix it, just live with it. Thats why I say -never buy this crap! Remember - skinflint always pays twice!

gr8t1

Tried factory resetTried Bluetooth optionsPhones says it's got 4G … Tried factory resetTried Bluetooth optionsPhones says it's got 4G signal.Text and data work fine.



In your settings. Turn it to 3G only. Then try if it fixes it it's a mast fault.

Known issue?
That'll be why I've never had it ever.
What rom are you using?

I'm not a skinflint either, and don't automatically dis apple, others in this house love them. I prefer my phones to actually last a full day without dying however.
Doesn't an apple user pay thrice for tech anyway?

Rimi

Known issue with Xiaomi; my 3 mates have same issue. No-one can fix it, … Known issue with Xiaomi; my 3 mates have same issue. No-one can fix it, just live with it. Thats why I say -never buy this crap! Remember - skinflint always pays twice!


























I read on google other phones also experience this problem sometimes if using wifi or VoLTE calling. Try disabling calls using VoLTE (4G) settings. If you are using MIUI 8, I think you need to go Settings>Sim cards and mobile networks>VoLTE enabled (under the Mobile data).


Only ring your mrs when she is beside you,that should help.

Original Poster

Rimi

Known issue with Xiaomi; my 3 mates have same issue. No-one can fix it, … Known issue with Xiaomi; my 3 mates have same issue. No-one can fix it, just live with it. Thats why I say -never buy this crap! Remember - skinflint always pays twice!


Go and troll another thread.

Original Poster

Tried disabling Volte
Tried 2G and 3G.
Weird how it only happens at home so far, haven't experienced anywhere else

Original Poster

Miui global 8.1
Should I try flashing a different Rom

I have the same phone and had no problems. I'm interested to here about it though. What happens when you use a set of buds with a mic or Bluetooth headset? I get a rom update every month so you would of thought it would get fixed if a known issue. Oh. I'm on the tesco network so I wonder if the problem is with your provider.. Strange though.

gr8t1

Tried disabling VolteTried 2G and 3G.Weird how it only happens at home so … Tried disabling VolteTried 2G and 3G.Weird how it only happens at home so far, haven't experienced anywhere else



I am 95% sure it will be an issue with the mast. Ask by to raise a fault ticket with ee for an engineer to check the local mast. It has probably already been picked up automatically if there is a fault but if you complain then it will help push it through faster.

However as has been said above it may be the phone if I was in work I would check to see if there was a local fault for you.

Original Poster

Wow fixed it.
We've recently been upgraded to 4G and it conflicts with the phone.
Sorry about earlier posts, I had switched it to 3G previously with no success, but you have to reboot the phone once you change from LTE to 3G for the change to take effect. Never knew this before.
Did that on both phones and problem has disappeared.

Happy days

Thanks everyone......
Well most
Post a comment
Avatar
@
    Text
    Top Discussions
    1. Gatwick Airport Parking22
    2. Foo fighters presale code.3743
    3. Is the Feedback section still monitored?11
    4. Domain renewal22

    See more discussions