Groups

    Abs light won't go off on my vectra

    Hi suddenly my abs light is now showing on the dashboard on my vectra, just worried it could be my breaks. Anyone on the know out there thanks

    12 Comments

    Check your brake fluid reservoir. Could be a faulty sensor.

    more then likely a wheel speed sensor, it needs to be plugged into a fault code reader.

    dont panic your brakes will still work fine, you just wont have any anti lock facility, plus its an mot failure.

    My sister has the same problem. She has been to four different garages who cannot find what is causing the warning light to come on.

    Original Poster

    diamondnine;5714266

    My sister has the same problem. She has been to four different garages … My sister has the same problem. She has been to four different garages who cannot find what is causing the warning light to come on.



    mmm,will have to get my dad to have a look at it

    I had same problem and it was something to do with sensors on your breaks.Sometimes there is too much dirt and it just needs to be cleaned up,or you can simply remove fuse from your fuse box and you will have no warning light on,your breaks will still work as normal,just abs will not until fixed.

    suddenly my abs light is now showing on the dashboard on my vectra, just worried it could be my breaks.


    sorry but i did lol!! the ABS light being anti lock breaks meaning there is a fault in the breaking system somewhere!! probably nothing too serious tho these things are usually more hassle than they are worth :thumbsup:

    does no one know how to spell brakes?

    Just had the similar problem on our honda accord - rear right abs sensor broke, £100+fitting. ECU could only be diagnosed at a main dealer. Brakes worked fine but non working ABS is a MOT failure so get it fixed asap (took honda 2 weeks to get our part so car was off the road with no MOT....)

    cheeky_chops;5716788

    does no one know how to spell brakes?Just had the similar problem on our … does no one know how to spell brakes?Just had the similar problem on our honda accord - rear right abs sensor broke, £100+fitting. ECU could only be diagnosed at a main dealer. Brakes worked fine but non working ABS is a MOT failure so get it fixed asap (took honda 2 weeks to get our part so car was off the road with no MOT....)




    only you smarty pants :thumbsup:

    err I would get it checked out - brakes are serious problem if you dont have them

    Check your brake fluid level first off it may be something that simple.

    try disconecting the battery and leave over night then reconnect this will reset your ECU and may sort it

    also did a little search on google and the sensors are known to fail on these so it probably that

    Had the same problem - intermittent ABS light. Usually wouldn't come on/disappear if I waited a few secs before starting the engine (half turn key).

    i have the same problem on my focus.. mechanic said it was probably a sensor.. I've driven it for a year or more like it. Sometimes it wont show for a few weeks.

    vaxhalls are a nightmare for that!!! it was our sensors! cost a ffew quid as the garage check every sensor!

    Take the bulb out. You won't notice the difference anyway.
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. Just heard this...2 ★★★★★★★★★★★★★★ congrats to all on 392k ★★★★★★★★★★★★★★7767233
      2. What's the most impressive 4k / UHD film you have seen at home?813
      3. What do you feel like whinging about today?1927345
      4. Try buy that Minecraft Xbone Argos deal? 10% online code in your email!1010

      See more discussions