Groups

    Acer Aspire Timeline 1810TZ ----------> help

    I have a new Acer 1810TZ and the ESC key seems not to be as responsive as the other keys so you don't get the clicky sound as with the other keyboard keys. I pushed the key down a few times with a bit of force and it made like a different clicking (louder) sound and it not doing it anymore. The key is still the same. I tried it with a few other keys by pushing down with pressure and it made the same sounds but now does not. Thekey still seems to work (esc) but is not responsive its like there is nothing underneath or something is blocking the esc key.


    What is likely to have caused this and am I likely to have damaged the keyboard by pushing down on it with pressure? (this is driving me crazy as im worried i have damaged it) or am i just being silly? I'm worried i might have damaged the keyboard circuit under the keys or connections for the keys itself to the board??

    Any help very much appreciated.

    Sabrina

    1 Comment

    If it's new and not working properly, just take it back to where you bought it from and get it replaced.
    Post a comment
    Avatar
    @
      Text
      Top Discussions
      1. Are these two things distinctly different to you?99
      2. So, whose already pre-ordered a Scorpio and where from?44
      3. ❅☁☁❅ I want☼to talk☼about the☔WEATHER☔no politics☃no religion❅☁☁❅18846240
      4. 'Hard' Brexit offers '£135bn annual boost' to economy - BBC News66

      See more discussions