Any idea how to disable the palm check function on a Microsoft Surface 3?

6
Found 26th May 2016
I have a Surface 3 - and have been using it to play a few games from the store. It has this annoying palm check feature that means the touchpad is disabled if I am pressing a keyboard key. So if I want to pan around whilst moving in World of Tanks for example, the touchpad doesn't work.

With my old Dell laptop, there was a dedicated function in mouse options that allowed me to disable this feature. Googling the issue hasn't brought up any solutions - so I'm just wondering if anyone else has had this issue, and/or knows a fix.

Thank you
Community Updates
AskMicrosoftSurface
6 Comments
https://www.google.co.uk/search?q=disable+palmcheck&oq=disable+palm&aqs=chrome.1.69i57j0l3.1984j0j4&client=ms-android-samsung&sourceid=chrome-mobile&ie=UTF-8

Explains it at the top, does that help?
Original Poster

https://www.google.co.uk/search?q=disable+palmcheck&oq=disable+palm&aqs=chrome.1.69i57j0l3.1984j0j4&client=ms-android-samsung&sourceid=chrome-mobile&ie=UTF-8Explains it at the top, does that help?



I wish it did ... but the Surface doesn't have that option in the settings. (My old Dell laptop did). I could of course use an external mouse - but that would make it less mobile.

Will keep Googling
Editor
Are you using Windows 10 or 8?

Had a look on my Surface 4 and don't see any options in track pad that would disable this on Windows 10.
Editor
https://www.reddit.com/r/Surface/comments/1bjte0/surface_pro_type_cover_palm_check_can_i_disable_it/?

Looks to be hardware related which is a shame
Original Poster

Are you using Windows 10 or 8?Had a look on my Surface 4 and don't see … Are you using Windows 10 or 8?Had a look on my Surface 4 and don't see any options in track pad that would disable this on Windows 10.



My Surface is running Windows 10.

(My Dell laptop is also on Windows 10 - but has a dedicated piece of Synaptics software that allows me to disable palmcheck. Seems strange for a company like Microsoft....that touts mobile gaming....to omit such an option!)


https://www.reddit.com/r/Surface/comments/1bjte0/surface_pro_type_cover_palm_check_can_i_disable_it/?Looks to be hardware related which is a shame



Hmm...annoying! Guess I'll just have to put up with being a sitting duck in the various games I play
Editor

Are you using Windows 10 or 8?Had a look on my Surface 4 and don't see … Are you using Windows 10 or 8?Had a look on my Surface 4 and don't see any options in track pad that would disable this on Windows 10.

https://www.reddit.com/r/Surface/comments/1bjte0/surface_pro_type_cover_palm_check_can_i_disable_it/?Looks to be hardware related which is a shame



Think it's more to do with the type cover and how it works than a specific driver issue. Using an external mouse would work, but obviously wouldn't be as portable
Post a comment
Avatar
@
    Text

    Top Discussions

    Top Merchants