ATI 5750 graphics settings

    Hey folks,
    I was running Sims 3 on the ATI 5750 with a quad core processor. Thing is I bumped everything on the game settings up to max, it was running ok but then started to get some spikes (lag) as i was panning left and right and being furthest out (looking at the town)

    Is there any way I can get the max settings without getting spikes now and again on the game, can I go into the ATI settings and boost it or something?
    I have heard of the overclocking but would this work and would it be ok on my comp lol

    thanks all


    Not sure what OS you have but this sounds like a driver issue, If you have not already have you tried installing the latest Drivers for the GPU? and having a look at what they fix?

    I would avoid overclocking, you can do this but its never good really even if it does make a lot of things better, and can bring problems in and you are never quite sure if it will lessen the life of your card.

    I seem to remember a test when The Sims 3 came out that commented that this behavior didn't disappear until you hit ridiculous frame rates (I think it was a couple of hundred fps from multiple GTX 280s). A bug in the code I guess, although I'm surprised it hasn't been patched. I assume you've got the latest patch?

    Original Poster

    yes got the latest 1.7 patch and latest drivers

    My OS is Win 7 ultimate I tried bringing the levels in the settings down a bit and it helped
    Post a comment
      Top Discussions
      1. Teenage son new phone (1250 budget)58
      2. Gaming PC Upgrade Help11
      4. Is it worth spending £20k on a car?1621

      See more discussions